A Knight‘s Journey

A Knight’s Journey

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 73299 Accepted: 25230
Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
Sample Input

3
1 1
2 3
4 3
Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
Source

TUD Programming Contest 2005, Darmstadt, Germany

分析:

判断有解无解问题采用深度优先遍历,
找最短路径采用广度优先遍历
注意题目中要求字典序输出,则遍历顺序很重要,必须按照这个顺序去遍历

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
ll n,k,flag,p,q;
int v[51][51],b[100010];
string s,c;
struct node{
	int x;
	int y;
}path[30];
//注意字典序 
int dx[8]={-1,1,-2,2,-2,2,-1,1};///x为行数,纵坐标
int dy[8]={-2,-2,-1,-1,1,1,2,2};///y为列数,横坐标
//int dir[8][2]={{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};
void dfs(int x,int y,int step){
	path[step].x=x;
	path[step].y=y;
	//结束条件 
	if(step==p*q){
		flag=1;
		for(int i=1;i<=step;i++)
		    printf("%c%d",path[i].y+'A'-1,path[i].x);
		cout<<endl;
		return;
	}
	for(int i=0;i<8;i++){
		int nx=x+dx[i];
		int ny=y+dy[i];
		if(nx>=1&&nx<=p&&ny>=1&&ny<=q&&v[nx][ny]==0&&flag==0){
			v[nx][ny]=1;
			dfs(nx,ny,step+1);
			v[nx][ny]=0; 
		}
	} 
}
int main(){
	while(cin>>n){
		if(n==0) break;
		for(int i=1;i<=n;i++){
			cin>>p>>q;
			flag=0;
			memset(v,0,sizeof(v));
			memset(path,0,sizeof(path));
			v[1][1]=1;
			cout<<"Scenario #"<<i<<":"<<endl;
			dfs(1,1,1);
			if(!flag)
			    cout<<"impossible"<<endl<<endl;
			else cout<<endl;
	    }	
	}
	return 0;
}
  • 10
    点赞
  • 20
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值