PAT 1157 Anniversary

该程序用于统计参加浙江大学122周年校庆的校友人数,并找出其中最年长的校友ID。首先读取校友信息,然后读取参加庆典的人员信息,通过映射数据结构记录。输出参加庆典的校友数量,如果无校友参加,则输出最年长的嘉宾ID。程序使用了map来高效地处理数据。
摘要由CSDN通过智能技术生成

1157 Anniversary (25 分)

Zhejiang University is about to celebrate her 122th anniversary in 2019. To prepare for the celebration, the alumni association (校友会) has gathered the ID's of all her alumni. Now your job is to write a program to count the number of alumni among all the people who come to the celebration.

Input Specification:

Each input file contains one test case. For each case, the first part is about the information of all the alumni. Given in the first line is a positive integer N (≤105). Then N lines follow, each contains an ID number of an alumnus. An ID number is a string of 18 digits or the letter X. It is guaranteed that all the ID's are distinct.

The next part gives the information of all the people who come to the celebration. Again given in the first line is a positive integer M (≤105). Then M lines follow, each contains an ID number of a guest. It is guaranteed that all the ID's are distinct.

Output Specification:

First print in a line the number of alumni among all the people who come to the celebration. Then in the second line, print the ID of the oldest alumnus -- notice that the 7th - 14th digits of the ID gives one's birth date. If no alumnus comes, output the ID of the oldest guest instead. It is guaranteed that such an alumnus or guest is unique.

Sample Input:

5
372928196906118710
610481197806202213
440684198612150417
13072819571002001X
150702193604190912
6
530125197901260019
150702193604190912
220221196701020034
610481197806202213
440684198612150417
370205198709275042

Sample Output:

3
150702193604190912

思路:

没啥坑点,正常模拟就行,用map会方便一点 

#include<bits/stdc++.h>
using namespace std;
#define ll long long
map<string, int>alum;
map<string, int >guest;
map<string, int>comealum;
int main()
{
	int n; cin >> n;
	string s;
	for (int i = 1; i <= n; ++i)
	{
		cin >> s;
		alum[s] = 1;
	}
	int m; cin >> m;
	for (int i = 1; i <= m; ++i)
	{
		cin >> s;
		guest[s] = 1;
		if (alum[s] == 1)
		{
			comealum[s] = 1;
		}
	}
	cout << comealum.size()<<endl;
	string ans = "";
	string tmp = "9";
	if (comealum.size() == 0)
	{
		for (auto it = guest.begin(); it != guest.end(); it++)
		{
			string ss=it->first;
			string s = ss.substr(6, 8);
			if (s < tmp)
			{
				tmp = s;
				ans = ss;
			}
		}
	}
	else
	{
		for (auto it = comealum.begin(); it != comealum.end(); it++)
		{
			string ss = it->first;
			string s = ss.substr(6, 8);
			if (s < tmp)
			{
				tmp = s;
				ans = ss;
			}
		}
	}
	cout << ans << endl;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值