Description
编写一个程序,输入a、b、c三个值,输出其中最大值。
Input
一行数组,分别为a b c
Output
a b c其中最大的数
Sample Input
10 20 30
Sample Output
30
HINT
Source
#define _CRT_SECURE_NO_WARNINGS 1
#include <stdio.h>
int MAX(int x, int y, int z)
{
if (x > y)
{
if (x > z)
return x;
else
return z;
}
else
{
if (y > z)
return y;
else
return z;
}
}
int main()
{
int a = 0;
int b = 0;
int c = 0;
scanf("%d %d %d", &a, &b, &c);
int max = MAX(a, b, c);
printf("%d\n", max);
return 0;
}
所有代码仅用于自己记录学习使用,未免忘的太快,也可能有错,仅供参考。