(C++)1001 A+B Format (20 分)(PAT甲级)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

题目分析:

对于代码中的判断条件" (i + 1) % 3 == len % 3 && i != len - 1 "可以有以下推导过程:

以输入-1000000 9为例,两数之和为-999991,转换成string后如下表所示:

标号索引0123456
字符串999991

题目要求是每满3个数就加一个",",首先共有7个字符,7%3=1,所以不满3个一组的数只有1个。

按照上表的情况应该是在标号3和4之间加入",",可以发现标号的规律是满足(标号+1)%3==1的时候需要在该数的后面加入",",但是要排除该数是字符串的最后一个字符的情况。

此外,还要注意当字符串首位有负号的时候要跳过。

这样一来这题就很简单啦~

程序代码如下:

#include <iostream>
using namespace std;
int main() {
    int a, b;
    cin >> a >> b;//输入两个整数
    int num=a+b;
    string str = to_string(num);//将两数之和转换为string类型
    int len = str.length();
    for (int i = 0; i < len; i++) {
        cout << str[i];
        if (str[i] == '-') continue;//如果结果有负号"-"则跳过
        if ((i + 1) % 3 == len % 3 && i != len - 1) cout << ",";//判断何时添加","
    }
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值