F

Given N numbers, X1, X2, … , XN, let us calculate the difference of every pair of numbers: ∣Xi - Xj∣ (1 ≤ i < j ≤ N). We can get C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!

Note in this problem, the median is defined as the (m/2)-th smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of m = 6.

Input
The input consists of several test cases.
In each test case, N will be given in the first line. Then N numbers are given, representing X1, X2, … , XN, ( Xi ≤ 1,000,000,000 3 ≤ N ≤ 1,00,000 )

Output
For each test case, output the median in a separate line.

Sample Input
4
1 3 2 4
3
1 10 2
Sample Output
1
8

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int sum[100002];int lop[16000001],kol[16000001];
int judge(int x,int mid){
    int sum1=0;
    for(int i=1;i<=sum[0];i++)
        {int k=sum+sum[0]+1-upper_bound(sum+1,sum+sum[0]+1,sum[i]+x);
        sum1+=k;}
       // cout<<x<<" "<<sum1<<endl;
    if(sum1<=mid)//
        return true;
    else return false;
}
int main(){
    int n;
    while(~scanf("%d",&n)){
    sum[0]=n;
    for(int i=1;i<=n;i++)
        scanf("%d",&sum[i]);
    sort(sum+1,sum+n+1);
    long long num=(n-1)*n/2;
    num/=2;
    int maxx=sum[n]-sum[1];
    int l=0;
    while(l<maxx)
    {
        int mid=(l+maxx)>>1;

        if(judge(mid,num))
            maxx=mid;
        else l=mid+1;//左侧寻找模板要l=mid+1否则容易无限循环
    }
    cout<<maxx<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值