1155 Heap Paths (30 分)(构建树)

360 篇文章 3 订阅
91 篇文章 1 订阅

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:
For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

结尾无空行
Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

结尾无空行
Sample Input 2:

8
8 38 25 58 52 82 70 60

结尾无空行
Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

结尾无空行
Sample Input 3:

8
10 28 15 12 34 9 8 56

结尾无空行
Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

结尾无空行

本题,应该没有人会用我这么蠢得办法了,明明可以直接弄堆进行求解,我非要先把 堆 -> 树 -> 求解,虽然多此一举,但还是把题做出来了,做完此题,我就要去学习堆了!

根据层次遍历构建树,构建完以后深搜求路径,然后判断是否是大大顶或小顶堆。

算是复习回顾了一下回溯和深搜把,由于 树有左右节点,所以回溯的时候,两边都要 pop

#include<iostream>
#include<string>
#include<algorithm>
#include<bits/stdc++.h>
#include<stack>
#include<set>
#include<vector>
#include<map>
#include<queue>
#include<deque>
#include<cctype>
#include<unordered_set>
#include<unordered_map>
#include<fstream>
#include<cstring>
using namespace std;
int n;
const int N = 1001;
int a[N], isMin = 1, isMax = 1;
typedef struct Node {
	int val;
	struct Node *left, *right;
} Node,*Tree;
Tree root = NULL;
void createTree() {
	int i = 1;
	queue<Tree> qu;
	Tree tree = (Tree)malloc(sizeof(Node));
	tree->val = a[i];
	tree->left = tree->right = NULL;
	if (i == 1) {
		root = tree;
	}
	qu.push(tree);
	i++;
	while (i <= n && !qu.empty()) {
		Tree t = qu.front();
		qu.pop();
		Tree l1 = new Node();
		l1->val = a[i++];
		Tree l2 = new Node();
		if (i <= n) {
			l2->val = a[i++];
			l2->left = NULL;
		}
		l1->left = l1->right = NULL;
		t->left = l1;
		qu.push(l1);
		if (i <= n) {
			t->right = l2;
		}
		qu.push(l2);
	}
}
vector<int> path;
vector<vector<int>> v;
void Dfs(Tree tree) {
	path.push_back(tree->val);
	if (!tree->left && !tree->right) {
		v.push_back(path);
		return;
	}
	if (tree->right != NULL) {
		Dfs(tree->right);
		path.pop_back(); 
	}
	
	if (tree->left != NULL) {
		Dfs(tree->left);
		path.pop_back(); 
	}
	
}
int main() {
	cin >> n;
	for (int i = 1; i <= n; i++) {
		cin >> a[i];
	}
	createTree();
	Tree tree = root;
	Dfs(tree);
	for (int i = 0; i < v.size(); i++) {
		for (int j = 0; j < v[i].size(); j++) {
			if (!j) {
				cout << v[i][j];
			} else {
				cout << " " << v[i][j];
			}
		}
		cout << endl;
	}
	for (int i = 2; i <= n; i++) {
		if (a[i / 2] > a[i]) {
			isMin = 0;
		}
		if (a[i / 2] < a[i]) {
			isMax = 0;
		}
	}
	if (isMin == 1)
        printf("Min Heap");
    else 
        printf("%s", isMax == 1 ? "Max Heap" : "Not Heap"); 
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_努力努力再努力_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值