PAT-甲级-1147 Heaps (30 分)

60 篇文章 0 订阅

1147 Heaps (30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

题目大意:已知一棵完全二叉树CBT,给定层序序列,判断这棵CBT是最大堆Max Heap还是最小堆Min Heap,如果都不是输出Not Heap ;

解题思路:

  • 由完全二叉树的性质,下标j(j=0)的左孩子下标为2 * j + 1、右孩子为2 * j + 2;
  • 先判断根与左孩子的关系,flag=1是最大堆,flag=-1是最小堆;
  • 遍历层序,当flag==1是最大堆,而父节点 < 左孩子、或者在2*j+2 < m的情况下,父节点 < 右孩子,判定为Not Heap;
  • 最后再dfs输出后序序列。
#include <iostream>
#include <vector>
using namespace std;
#define rep(i,j,k)	for(int i=j;i<k;i++)
vector<int> v;
int n,m;
void dfs(int index){
	if(index >= m) return;
	dfs(2*index+1);
	dfs(2*index+2);
	printf("%d%s",v[index],index == 0 ?"\n":" ");
}
int main(){
	std::ios::sync_with_stdio(false);
	cin>>n>>m;
	v.resize(m);
	while(n--){
		rep(i,0,m)
			cin>>v[i];
		int flag = v[0] > v[1] ? 1 : -1;
		for(int j = 0;j <= (m-1) / 2;j++){
			int l = 2 * j + 1,r = 2 * j + 2;
			if(flag == 1 && ((v[j] < v[l]) || (r < m && v[j] < v[r])))
				flag = 0;
			if(flag == -1 && ((v[j] > v[l]) || (r < m && v[j] > v[r])))
				flag = 0;
		}
		if(flag == 0)   printf("Not Heap\n");
		else    printf("%s Heap\n",flag==1?"Max":"Min");
		dfs(0);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值