PAT A1001 A+B Format (20分)

1001 A+B Format (20分)
Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10
​6
​​ ≤a,b≤10
​6
​​ . The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:
-1000000 9
Sample Output:
-999,991

#include <cstdio>

int main(){
	int a, b, res, t[10];
	scanf("%d %d", &a, &b);
	res = a + b;
	
	if(res < 0){
		printf("-");
		res = -res;
	}
	
	int num = 0;
	if(res == 0){
		printf("0");
	}else{
			while(res != 0){
			t[num] = res % 10;
			num++;
			res /= 10;
		}
		
		
		int flag = 0;
		int temp = num % 3;
		for(int i=num-1; i>=0; i--){
			printf("%d", t[i]);
			flag++;
			if(flag%3==temp && i!=0){
				printf(",");
			}
		}
	}
	
	
	
	return 0;
}

有一说一我觉得这题还是挺简单的,但是因为算法笔记中分类在字符串处理那章,所以刚拿到题目不自觉的在想用字符串来解决。用字符串的话必须要能把数字给转成字符,这有点超出了我的能力范围,所以就放弃了。因为这题整数的范围在int内,所以可以直接相加出结果,然后将每一位数字保存在一个数组中,然后输出数组,隔三位输出一个逗号。
这题有两个坑,一个是结果长度小于4的时候不用输出逗号,所以要记住三位数的时候应该判断一下数组是否都输出完了。还有一个是结果为0的时候,需要特判。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
可以使用面向对象的思想来构建“超市购物”程序。我们可以先定义两个类,一个是商品类,一个是购物者类。商品类中包含属性货物名、货号、价格和数量等信息,还包含获取货物名和价格的方法。购物者类中包含购物清单和购买商品等方法。在购物者类中先定义购物清单列表,再根据购买的商品名称查找商品的价格并计算出总价格。每次购买商品时,还需要统计相应商品的销售数量。 下面是一个示例代码: ```python class Commodity: def __init__(self, name, code, price, quantity): self.name = name self.code = code self.price = price self.quantity = quantity def get_name(self): return self.name def get_price(self): return self.price class Shopper: def __init__(self): self.shopping_list = [] # 初始化购物清单 def add_item(self, commodity, quantity): # 添加购买的商品和对应数量 self.shopping_list.append((commodity, quantity)) def print_receipt(self): # 打印购物清单和总价格 total_price = 0 for commodity, quantity in self.shopping_list: name = commodity.get_name() price = commodity.get_price() sub_total = price * quantity total_price += sub_total print(f"{name} x {quantity} = {sub_total}") print(f"Total price: {total_price}") # 统计销售数量 for commodity, quantity in self.shopping_list: commodity.quantity += quantity # 定义一些商品 commodity1 = Commodity("soap", "A1001", 10, 100) commodity2 = Commodity("pen", "A1002", 5, 200) # 创建购物者并购买商品 shopper = Shopper() shopper.add_item(commodity1, 2) shopper.add_item(commodity2, 3) # 打印购物清单并统计销售数量 shopper.print_receipt() print(commodity1.quantity) print(commodity2.quantity) ``` 运行结果: ``` soap x 2 = 20 pen x 3 = 15 Total price: 35 102 203 ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值