1077 Kuchiguse (20分)
The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker’s personality. Such a preference is called “Kuchiguse” and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle “nyan~” is often used as a stereotype for characters with a cat-like personality:
Itai nyan~ (It hurts, nyan~)
Ninjin wa iyada nyan~ (I hate carrots, nyan~)
Now given a few lines spoken by the same character, can you find her Kuchiguse?
Input Specification:
Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character’s spoken line. The spoken lines are case sensitive.
Output Specification:
For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.
Sample Input 1:
3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~
Sample Output 1:
nyan~
Sample Input 2:
3
Itai!
Ninjinnwaiyada T_T
T_T
Sample Output 2:
nai
#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
int main(){
int n, len;
scanf("%d", &n);
getchar();
char str[100][260];
int minlen = 300;
for(int i=0; i<n; i++){
cin.getline(str[i], 260);
len = strlen(str[i]);
if(len < minlen){
minlen = len;
}
for(int j=0; j<len/2; j++){
swap(str[i][j], str[i][len-j-1]);
}
}
int ans = 0;
for(int i=0; i<minlen; i++){
for(int j=1; j<n; j++){
if(str[j][i] != str[0][i]){
goto here;
}
}
ans++;
}
here:
if(ans != 0){
for(int i=ans-1; i>=0; i--){
printf("%c", str[0][i]);
}
}else{
printf("nai");
}
return 0;
}
啊啊啊啊啊啊啊啊啊啊好难受啊这题,折磨了我一小时,测试点3一直过不去,最后发现是我的长度变量len居然设的是char型???(话说其他测试点是怎么过的???)粗心的毛病老是改不掉啊!!!