数论练习集

B

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, … shows the first 20 humble numbers.

Now given a humble number, please write a program to calculate the number of divisors about this humble number.For examle, 4 is a humble,and it have 3 divisors(1,2,4);12 have 6 divisors.

Input
The input consists of multiple test cases. Each test case consists of one humble number n,and n is in the range of 64-bits signed integer. Input is terminated by a value of zero for n.
Output
For each test case, output its divisor number, one line per case.
Sample Input
4
12
0
Sample Output
3
6
题意:刚开始自己还以为就是求一个数的除数个数,原来是读错题了,题目是 求 一个数的 所有约数 质数 只有 2,3,5,7这四个,求这个数的除数
思路:结论结论:如果一个数可以表达成num=a^x * b^y * c^z…,则num的约数个数为(a+1)(b+1)(c+1)*…;就是这么不讲道理

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<string>
#include<queue>
#include<vector>
using namespace std;
#define inf 0x3f3f3f3f3f;
typedef long long ll;
int main()
{
	ll n; ll a, b, c, d;
	while (cin >> n&&n)
	{
		a = b = c = d = 1;
		while (n != 1)
		{
			if (n % 2 == 0)
			{
				a++; n /= 2;
			}
			if (n % 3 == 0)
			{
				b++; n /= 3;
			}
			if (n % 5 == 0)
			{
				c++; n /= 5;
			}
			if (n % 7 == 0)
			{
				d++; n /= 7;
			}
		}
		cout << a * b * c * d << endl;
	}

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值