hud 1312 BFS

hdu 1312 Red and Black

问题描述

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
‘.’ - a black tile

‘#’ - a red tile

‘@’ - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
…#.
…#





#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.

11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0

Sample Output

45
59
6
13

思路:建立坐标系记录瓷砖的状态,将坐标点放入队列,先进入队列的先出队列,移动坐标搜索可到达的瓷砖并进行标记,同时检测当前所处的坐标位置是否属于该房间。

#include<iostream>
#include<queue>
using namespace std;
char room[22][22];
int dir[4][2]={    //点的移动方向 
 {-1,0},     //向左移动 
 {0,-1},     //向上移动 
 {1,0},     //向右移动 
 {0,1}     //向下移动 
};
int Wx,Hy,mum;
struct point{int x,y;};
#define check(x,y)(x<Wx&&x>=0&&y<Hy&&y>=0)//检测当前点的位置是否在room内 
void bfs(int dx,int dy){
 mum=1;         //起点包括在总瓷砖数中 
 queue<point>q;        
 point start,next;
 start.x=dx;
 start.y=dy;
 q.push(start);       //把start放入队列 
 while(!q.empty()){
  start=q.front();
  q.pop();
  for(int i=0;i<4;i++)    //按左、上、右、下的方向逐一进行搜索 
  {
   next.x=start.x+dir[i][0];
   next.y=start.y+dir[i][1];
   if(check(next.x,next.y)&&room[next.x][next.y]=='.'){
    room[next.x][next.y]='#';       //将进队之后的点标记为'#',表示已经处理过 
    mum++;
    q.push(next);
   }
  }
 }
}
int main()
{
 int x,y,dx,dy;
 while(cin>>Wx>>Hy)     //Wx为列,Hy为行 
 {
  if(Wx==0&&Hy==0)break;
  for(y=0;y<Hy;y++)
  {
   for(x=0;x<Wx;x++)
   {
    cin>>room[x][y];
    if(room[x][y]=='@'){
     dx=x;
     dy=y;
    }
   }
  }
  mum=0;
  bfs(dx,dy);
  cout<<mum<<endl;
 }
 return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值