P2947 [USACO09MAR] Look Up S(向右看齐)

P2947 [USACO09MAR] Look Up S(向右看齐)

题目描述

Farmer John’s N (1 <= N <= 100,000) cows, conveniently numbered 1…N, are once again standing in a row. Cow i has height H_i (1 <= H_i <= 1,000,000).

Each cow is looking to her left toward those with higher index numbers. We say that cow i ‘looks up’ to cow j if i < j and H_i < H_j. For each cow i, FJ would like to know the index of the first cow in line looked up to by cow i.

Note: about 50% of the test data will have N <= 1,000.

约翰的 N ( 1 ≤ N ≤ 1 0 5 ) N(1\le N\le10^5) N(1N105) 头奶牛站成一排,奶牛 i i i 的身高是 H i ( 1 ≤ H i ≤ 1 0 6 ) H_i(1\le H_i\le10^6) Hi(1Hi106)。现在,每只奶牛都在向右看齐。对于奶牛 i i i,如果奶牛 j j j 满足 i < j i<j i<j H i < H j H_i<H_j Hi<Hj,我们可以说奶牛 i i i 可以仰望奶牛 j j j。 求出每只奶牛离她最近的仰望对象。

输入格式

  1. * Line 1: A single integer: N

* Lines 2…N+1: Line i+1 contains the single integer: H_i

1 1 1 行输入 N N N,之后每行输入一个身高 H i H_i Hi

输出格式

* Lines 1…N: Line i contains a single integer representing the smallest index of a cow up to which cow i looks. If no such cow exists, print 0.

N N N 行,按顺序每行输出一只奶牛的最近仰望对象,如果没有仰望对象,输出 0 0 0

样例 #1

样例输入 #1

6 
3 
2 
6 
1 
1 
2

样例输出 #1

3 
3 
0 
6 
6 
0

提示

FJ has six cows of heights 3, 2, 6, 1, 1, and 2.

Cows 1 and 2 both look up to cow 3; cows 4 and 5 both look up to cow 6; and cows 3 and 6 do not look up to any cow.

【输入说明】 6 6 6 头奶牛的身高分别为 3,2,6,1,1,2。

【输出说明】奶牛 #1,#2 仰望奶牛 #3,奶牛 #4,#5 仰望奶牛 #6,奶牛 #3 和 #6 没有仰望对象。

【数据规模】

对于 20 % 20\% 20% 的数据: 1 ≤ N ≤ 10 1\le N\le10 1N10

对于 50 % 50\% 50% 的数据: 1 ≤ N ≤ 1 0 3 1\le N\le10^3 1N103

对于 100 % 100\% 100% 的数据: 1 ≤ N ≤ 1 0 5 , 1 ≤ H i ≤ 1 0 6 1\le N\le10^5,1\le H_i\le10^6 1N105,1Hi106

解题

思想

使用单调栈

  • 从前往后遍历:前面比我小的出栈,我是第一个比前面出栈元素大的元素
  • 从后往前遍历:后面比我小的出栈(出栈元素不可能是前面元素的仰望对象了,因为比我还小),后面第一个比我大的就是仰望对象

代码

#include <bits/stdc++.h>
using namespace std;

int n, a[100001], b[100001];
stack<int> st;

int main( )
{
    cin >> n;
    for (int i = 0; i < n; i++)
    {
        cin>> a[i];
    }

    // 前面比我小的出栈,我是第一个比前面出栈元素大的元素
    for (int i = 0; i < n; i++)
    {
        while (!st.empty() && a[st.top()]<a[i])
        {
            b[st.top()]=i+1;
            st.pop();
        }
        st.push(i); 
        b[i] = 0;
    }

    for (int i = 0; i < n; i++)
    {
        cout <<b[i] << endl;
    }
    return 0;
}
#include <bits/stdc++.h>
using namespace std;

int n, a[100001], b[100001];
stack<int> st;

int main( )
{
    cin >> n;
    for (int i = 0; i < n; i++)
    {
        cin>> a[i];
    }

    for (int i = n-1; i >=0; i--)
    {
        // 后面比我小的出栈(出栈元素不可能是前面元素的仰望对象了,因为比我还小),后面第一个比我大的就是仰望对象
        while (!st.empty() && a[st.top()]<=a[i])
        {
            st.pop();
        }
        if (!st.empty())
        {
            b[i]=st.top()+1;
        }
        // else
        // {
        //     b[i] = 0;
        // }
        st.push(i); 
        
    }
    
    for (int i = 0; i < n; i++)
    {
        cout <<b[i] << endl;
    }

    return 0;
}

踩坑

注意没有仰望对象的元素如何处理

参考资料

[1] P2947 [USACO09MAR] Look Up S(向右看齐)
[2]

  • 23
    点赞
  • 12
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值