找割点

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N . No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is 
possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure 
occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

Input

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated 
by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0;

Output

The output contains for each block except the last in the input file one line containing the number of critical places.

Sample Input

5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0

Sample Output

1
2

Hint

You need to determine the end of one line.In order to make it's easy to determine,there are no extra blank before the end of each line.

每次先给出n,代表(1——n)个点,(以下有小于n行,每行的第一个数代表一个点,后边的代表与之相邻的某些点)。

除了有故障的地方无法到达外,还可能导致其他一些地方无法连接。在这种情况下,我们会说失败的地方

发生)是至关重要的。现在来找出所有这些关键地点的数量

按照找割点来求,注意一下输入时的格式要求,然后根据找割点的模板就可以写出来。

代码如下

#include<stdio.h>
#include<string.h>
int e[1100][1100],num[1100],low[1100],flag[1100],index,n,m,root;
int minn(int a,int b)
{
    return a<b?a:b;
}
void dfs(int cur,int father)
{
    int child=0,i;
    index++;
    num[cur]=index;
    low[cur]=index;
    for(i=1;i<=m;i++)
    {
        if(e[cur][i]==1)
        {
            if(num[i]==0)
            {
                child++;
                dfs(i,cur);
                low[cur]=minn(low[cur],low[i]);
                if(cur!=root&&low[i]>=num[cur])
                    flag[cur]=1;
                if(cur==root&&child==2)
                    flag[cur]=1;
            }
            else if(i!=father)
            {
                low[cur]=minn(low[cur],num[i]);
            }
        }
    }
    return;
}
int main()
{
    int i,j,h;
    while(scanf("%d",&m)&&m!=0)
    {
        memset(num,0,sizeof(num));
        memset(low,0,sizeof(low));
        memset(flag,0,sizeof(flag));
        for(i=1;i<=m;i++)
            for(j=1;j<=m;j++)
                e[i][j]=0;
        h=0;
        while(scanf("%d",&n)&&n!=0)
        {
            while(getchar()!='\n')
            {
                int v;
                scanf("%d",&v);
                e[n][v]=1;
                e[v][n]=1;
            }
        }
        root=1;
        dfs(1,root);
        for(i=1;i<=m;i++)
        {
            if(flag[i]==1)
               h++;
        }
        printf("%d\n",h);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值