Harmonic Number (II)

I was trying to solve problem ‘1234 - Harmonic Number’, I wrote the following code
long long H( int n ) {
long long res = 0;
for( int i = 1; i <= n; i++ )
res = res + n / i;
return res;
}
Yes, my error was that I was using the integer divisions only. However, you are given n, you have to find H(n) as in my code.
Input
Input starts with an integer T (≤ 1000), denoting the number of test cases.
Each case starts with a line containing an integer n (1 ≤ n < 231).
Output
For each case, print the case number and H(n) calculated by the code.
Sample Input
11
1
2
3
4
5
6
7
8
9
10
2147483647
Sample Output
Case 1: 1
Case 2: 3
Case 3: 5
Case 4: 8
Case 5: 10
Case 6: 14
Case 7: 16
Case 8: 20
Case 9: 23
Case 10: 27
Case 11: 46475828386
这是一个找规律题 规律不是很好想需要手推一下
f=n/x这个函数关于y = x 对称对称点刚好是sqrt(n),于是就简单了直接求sum+n/i (ii<n && i >=1),然后乘以2,再减去ii即可。

当n==10时,m=sqrt(10)13,f(10)(10+5+3)2-33=27;

关于m对称,左右相差mm,左边10+5+3=18,右边2+2+1+1+1+1+1=9,和左边相差33=9,
原文链接:https://blog.csdn.net/titi2018815/java/article/details/82223561
公式:
m=sqrt(n);
f(n)=(n/1+n/2+n/3+…+n/k)2-mm;(n/k<=m);

在这里插入代码片#include<stdio.h>
#include<string.h>
#include<math.h>
int main()
{
    int n,a=1;
    scanf("%d",&n);
   while(n--)
   {
        long long sum=0, m,l,r,i;
        scanf("%lld",&m);
         long long t=sqrt(m);
     for(i=1;i<=t;++i)
     {
         sum+=m/i;
         l=m/i;
         r=m/(i+1);
         if(l>r)
            sum+=(l-r)*i;
     }
        if(m/t==t)
            sum-=t;
        printf("Case %d: %lld\n",a++,sum);
   }
   return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值