A+B

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2
1 2
112233445566778899 998877665544332211
Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
思路 求2个数字的和 ,数字很大要用字符数组存 ,倒着存进数字数组中,再进行加减,判断最后一位是否为1,我的问题是判断每一位是否需要进位时直接用的d1[i]+d2[i]判断,而没有考虑进位

#include"stdio.h"
#include"string.h"
#include"algorithm"
#define INF 1000000
using namespace std;
const int N=1e6+10;
char a[10100],b[10100];
int d1[10100],d2[10100],sum[10100];
int main()
{
   int t,s=1;
   scanf("%d",&t);
   while(t--)
   {
       int k=0,x=0,y=0;
      scanf("%s %s",a,b);
      int l1=strlen(a);
      int l2=strlen(b);

      memset(d1,0,sizeof(d1));
      memset(d2,0,sizeof(d2));
      memset(sum,0,sizeof(sum));
      for(int i=l1-1;i>=0;i--)
        d1[x++]=a[i]-'0';
      for(int i=l2-1;i>=0;i--)
        d2[y++]=b[i]-'0';
      l1=max(l1,l2);
      for(int i=0;i<=l1;i++)
      {
          sum[i]=d1[i]+d2[i]+k;   //记录的是每一位的数  
          k=0;
          if(sum[i]>9)     //注意这里不能用d1[i]+d2[i]判断
          {
              sum[i]-=10;
              k=1;
          }
      }
      printf("Case %d:\n",s++);
      printf("%s + %s = ",a,b);
      if(sum[l1]==0)
      {
          for(int i=l1-1;i>=0;i--)
          printf("%d",sum[i]);
      }
      else
      {
           for(int i=l1;i>=0;i--)
          printf("%d",sum[i]);
      }
      if(t)
        printf("\n\n");
      else
        printf("\n");
   }
    return 0;
}
//1111111111111111110
//1111111111111111110
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值