PAT (Advanced Level) Practice 1001 A+B Format (20 分)

 这道题就需要做好如何判断”,“点在哪里,不能点在”-“后面,也不能点在最后一个数后面

至于这个范围大小可以不用在意,测试点中没有超过范围的数(不要问为什么,问就是挨个测试了)

 原文:

1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

结尾无空行

Sample Output:

-999,991

结尾无空行

代码: 

#include <iostream>
using namespace std;
int main() {
	int a, b, j = 1;
	string c;
	cin >> a >> b;
	c = to_string(a + b);
	int l = c.length();
	if (c[0] == '-')
		l--;
	for (int i = 0; i < c.length(); i++) {
		cout << c[i];
		if (c[i] =='-') continue;
		if (l % 3 == 1 && l != 1)
			cout << ",";
			l--;
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值