PAT甲级 1012 The Best Rank (25 分) 排序 细节

PAT甲级 1012 The Best Rank (25 分) 排序 细节

【题目描述】
To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

【输入】
Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

【输出】
For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

【样例输入】

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

【样例输出】

1 C
1 M
1 E
1 A
3 A
N/A

【解题思路】

很显然这是一道排序题,我们用结构体存数据,使用cmp函数进行排序。要注意的是,这道题细节很多。

比如当两个人分数相同时,排名的值相同,比如如果有4个人,中间2个人当前课程的分数并列,那么他们当前课程的排名分别是1,2,2,4。

另外要注意在选取最优排名时,各门科目的优先级,即A > C > M > E。为方便起见,我们数组下标1到3分别表示C、M、E三门课,下标0计算平均分A。

排序的时候用到一个小技巧,因为我们需要按照不同科目进行排序,统计名次,我们用一个全局变量sub,这样我们修改sub的值,使用cmp函数就能按照对应科目进行排序了。

最后我们使用一个map来记录每个学号是否存在,同时可以记录最终这个学号在结构体数组当中的位置。查询时,若输入的学号存在,输出答案即可,否则输出N/A。

【满分代码】

#include <iostream>
#include <cstdio>
#include <map>
#include <algorithm>
using namespace std;
int sub=0;
struct node
{
	string s;
	int grade[4],rank[4],best;
	char ans;
}c[2005];
bool cmp(node a,node b)
{
	return a.grade[sub]>b.grade[sub];
}
map<string,int> mp;
int main()
{
	ios::sync_with_stdio(0),cin.tie(0),cout.tie(0);
	int n,m;
	cin>>n>>m;
	for(int i=0;i<n;i++)
	{
		cin>>c[i].s>>c[i].grade[1]>>c[i].grade[2]>>c[i].grade[3];
		c[i].grade[0]=c[i].grade[1]+c[i].grade[2]+c[i].grade[3];
	}
	for(int i=0;i<=3;i++)
	{
		sub=i;
		sort(c,c+n,cmp);
		c[0].rank[i]=1;
		for(int j=1;j<n;j++)
		{
			if(c[j].grade[i]==c[j-1].grade[i])
				c[j].rank[i]=c[j-1].rank[i];
			else
				c[j].rank[i]=j+1;
		}
	}
	for(int i=0;i<n;i++)
	{
		mp[c[i].s]=i;
		int best=0,temp=2005;
		for(int j=0;j<=3;j++)
		{
			if(c[i].rank[j]<temp)
			{
				temp=c[i].rank[j];
				best=j;
			}
		}
		c[i].best=temp;
		if(best==0)
			c[i].ans='A';
		else if(best==1)
			c[i].ans='C';
		else if(best==2)
			c[i].ans='M';
		else
			c[i].ans='E';
	}
	string s;
	for(int i=0;i<m;i++)
	{
		cin>>s;
		if(mp.count(s))
		{
			cout<<c[mp[s]].best<<" "<<c[mp[s]].ans;
		}
		else
			cout<<"N/A";
		if(i!=m-1)
			cout<<endl;
	}
	return 0;
}
  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

球王武磊

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值