How Many Tables(hdu-1213)

点我跳转到 HDU - 1213

Problem Description

Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least.
You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2
4


解题思路

题意说的是有n个朋友来吃晚餐,但是这些朋友中有某些人是互相认识的
这些互相认识的可以安排到一张桌子上
互相不认识就每人需要多拿出一张桌子
要我们求至少需要多少张桌子可以解决
我们先把互相认识的人unite起来,然后find一下是否属于同一个集合就可以解决问题了

AC代码

#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 1010;
int Fa[maxn];
void init(int n)
{
	for(int i = 1 ; i <= n ; i++)
	{
		Fa[i] = i;
	}
}
int Find(int x)
{
	return Fa[x]==x?x:Fa[x]=Find(Fa[x]);
}
void unite(int a, int b)
{
	Fa[Find(a)] = Find(b);
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n,m;
		scanf("%d %d",&n,&m);
		init(n);
		int table = 0;
		for(int i = 0 ; i < m ; i++)
		{
			int a,b;
			scanf("%d %d",&a,&b);
			unite(a,b);//合并a b
		}
		for(int i = 1 ; i <= n ; i++)
		{
			//合并完成后 
			//有关系的Fa[] = 较大的Fa[]
			//他们共享较大的Fa[] 
			//如果等于i 既说明走到了较大的Fa[] 也说明走到了两人没有关系的
			//故table++;
			if(Fa[i] == i)//不同集合
			{
				table++;
			}
		}
		printf("%d\n",table);
	}
	return 0;
}
  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值