Wireless Network(POJ-2236)

点我跳转 POJ - 2236

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.
In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are
numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:

  1. “O p” (1 <= p <= N), which means repairing computer p.

  2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output

For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS


解题思路

题目大意是目前有n台坏的电脑,然后给一个指令去修复对应的p号电脑和做一些查询操作,两台d距离内的没有故障的电脑才能互连,要我们做一些判断,其实就是并查集的简单应用

首先我们用一个数组做标记已经修复的然后每次读到指令‘O’就对该点做标记,然后遍历所有的电脑,判断是否是同一个点,如果不是同一个点且满足在d距离内可以互连就把这两个点合并
读取到‘S’就判断一下是否是同一个集合,若是同一个集合就是已经合并过的可以互连的

AC代码

#include<iostream>
#include<algorithm>
#include<string>
#include<string.h>
using namespace std;
const int maxn = 1111;
int fa[maxn];
int vis[maxn];
struct node
{
	int x;
	int y;
}pos[maxn];
void init()
{
	for(int i = 0 ; i < maxn ;i++)
	{
		fa[i] = i;
	}
}
int Find(int x)
{
	return fa[x] == x?x:fa[x] = Find(fa[x]);
}
void unite(int x, int y)
{
	fa[Find(x)] = Find(y);
}
int distance(int x1,int y1,int x2,int y2)
{
	return ((x2-x1)*(x2-x1)+(y2-y1)*(y2-y1));
}
int main()
{
	init();
	memset(vis,0,sizeof(vis));
	int n , d;
	scanf("%d %d",&n,&d);
	for(int i = 1 ; i <= n ; i++)
	{
		scanf("%d %d",&pos[i].x,&pos[i].y);
	}
	string s;
	while(cin>>s)
	{
		if(s[0] == 'O')
		{
			int p;
			scanf("%d",&p);
			vis[p] = 1;//p号被修复
			for(int i = 1 ; i <= n ; i++)//遍历所有的电脑
			{
				if(vis[i] == 1)//修好的
				{
					if(i != p)//是否是另一台电脑
					{
						if(distance(pos[p].x,pos[p].y,pos[i].x,pos[i].y) <= d*d)//两点距离在d范围内
						{
							unite(p,i);
						}
					}
				}
			}
		}else
		{
			int p,q;
			scanf("%d %d",&p,&q);
			if(Find(p) == Find(q))
			{
				printf("SUCCESS\n");
			}else
			{
				printf("FAIL\n");
			}
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值