7084:迷宫问题 (BFS 搜索,输出路径问题 板子)

31 篇文章 0 订阅
30 篇文章 0 订阅

描述
定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

输入
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
输出
左上角到右下角的最短路径,格式如样例所示。
样例输入
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
样例输出
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

思路:BFS板子题
代码:

#include<cstdio>
#include<cstdlib>
#include<iostream>
#include<stack>
using namespace std;
const int N=7;
int mp[N][N];
int book[N][N];
struct note
{
    int x;
    int y;
    int f;
    int s;
};
int nest[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
struct note que[N*N];
int sx,sy,ex,ey;
int tx,ty;
struct node
{
    int x;
    int y;
};
stack <note> q;

void bfs()
{
    int head,tail;
    int flag=0;
    head=tail=1;
    tail++;
    que[head].x=0;
    que[head].y=0;
    que[head].s=0;
    que[head].f=0;
    while(head<tail)
    {
    for(int k=0; k<4; k++)
    {
        tx=nest[k][1]+que[head].x;
        ty=nest[k][0]+que[head].y;
        if(tx>=0 && tx<=4 && ty>=0 && ty<=4 && book[tx][ty]==0)
        {
            if(mp[tx][ty]==0)
            {
                que[tail].x=tx;
                que[tail].y=ty;
                que[tail].s=que[head].s+1;
                que[tail].f=head;
                book[tx][ty]=1;
                tail++;
            }
            if(tx==4 && ty==4)
            {
                flag=1;
                break;
            }

        }
    }
    if(flag==1)
        break;
    head++;
    }
    int t=tail-1;
    while(t)
    {
        q.push(que[t]);
        t=que[t].f;
    }
    struct note temp;
    while(!q.empty())
    {
        temp=q.top();

        printf("(%d, %d)\n",temp.x,temp.y);
        q.pop();
    }


}


int main()
{
    for(int i=0; i<5; i++)
    {
        for(int j=0; j<5; j++)
            cin>>mp[i][j];
    }
    sx=sy=0;
    ex=ey=4;
    bfs();
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值