【BFS】NOI 7084 迷宫问题

题目描述

OJ地址 http://noi.openjudge.cn/ch0205/7084/

定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

输入:

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

输出:

左上角到右下角的最短路径,格式如样例所示。

样例输入1:

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

样例输出1:

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

思路:

典型的最短路问题,但是需要记录最短路的路径,这里我用的办法是,在结构体内部开一个队列出来,记录每一步的坐标,到达终点时,依次出队就可以了。

代码

#include <bits/stdc++.h>

using namespace std;

int dir[4][2] = {{0,1},{-1,0},{0,-1},{1,0}}; 
bool vis[5][5]; 
int mp[5][5];
struct nn{
	int x,y,d;
	queue<pair<int,int> > qq;
	void pu(){
		qq.push(make_pair(x,y));
	}
} node;


int main(){
	for(int i = 0; i < 5; i++){
		for(int j = 0; j < 5; j++){
			cin >> mp[i][j];
		}
	} 
	node.x = 0;
	node.y = 0;
	node.d = 0;
	node.pu();  //存入这个点
	 
	queue<nn> q;
	q.push(node);
	while(!q.empty()){
		
		for(int i = 0; i < 4; i++){
			node.x = q.front().x + dir[i][0];
			node.y = q.front().y + dir[i][1];
			node.d = q.front().d + 1;
			node.qq = q.front().qq;
			
			if(node.x < 0 || node.x >=5 || node.y<0 || node.y >= 5 || vis[node.x][node.y] || mp[node.x][node.y] == 1){
				continue;
			}
		
			if(node.x == 4 && node.y == 4){
				
				node.pu();
				while(!node.qq.empty()){
					cout << "(" << node.qq.front().first << ", " << node.qq.front().second << ")" << endl;
					node.qq.pop();
				}			
				return 0;
			}
			
			if(mp[node.x][node.y] == 0){
				node.pu();
				q.push(node);
				vis[node.x][node.y] = true;
			}
			
		}
		q.pop();

	}
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值