Whose sum is zero(二分法)

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .
Input
The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2^ 28 ) that belong respectively to A, B, C and D .
Output
For each input file, your program has to write the number quadruplets whose sum is zero.
Sample Input6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45
Sample Output
5
Hint
Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).
拿题思想:这道题是要求解有多少组数据满足给出的等式,如果用普通的方法来求解的话,循环量十分的大;然后由于求A+B+C+D=0的个数,那么就可以转化为sum1=A+B;sum2=C+D;即sum1+sum2=0的情况;然后再根据二分法来做。
最终解题步骤
1)先对输入的a,b,c,d,中找出所有的sum1和sum2,并将sum2数组用sort函数进行排序,满足能使用二分法单调的条件;
2)进行二分法查找找出满足等式sum1+sum2=0的所有组合的个数总和;

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define m 4005
using namespace std;
int sum1[m*m],sum2[m*m];
int a[m],b[m],c[m],d[m];
int main()
{
    int n,mid;
    while(scanf("%d",&n)!=EOF)
        {
            for(int i=0;i<n;i++)
                cin>>a[i]>>b[i]>>c[i]>>d[i];
            int k=0,p=0,cnt=0;
            for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
                {
                    sum1[k++]=a[i]+b[j];
                    sum2[p++]=c[i]+d[j];
                }
            sort(sum2,sum2+k);
            for(int i=0;i<k;i++)
                {
                    int low=0;
                    int high=k-1;
                    while(low<=high)
                        {
                            mid=(low+high)/2;
                            if(sum1[i]+sum2[mid]==0)
                                {
                                    cnt++;
                                    for(int j=mid+1;j<k;j++)
                                        {
                                            if(sum1[i]+sum2[j]==0)
                                                cnt++;
                                            else break;
                                        }
                                    for(int j=mid-1;j>=0;j--)
                                        {
                                            if(sum1[i]+sum2[j]==0)
                                                cnt++;
                                            else break;
                                        }
                                    break;
                                }
                            if(sum1[i]+sum2[mid]<0)
                                low=mid+1;
                            else high=mid-1;
                        }
                }
            cout<<cnt<<endl;
        }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值