HDU 1005 Number Sequence[数论]

1 篇文章 0 订阅

题干

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output
For each test case, print the value of f(n) on a single line.

Sample Input
1 1 3
1 2 10
0 0 0

Sample Output
2
5

题解

/**
*做这个题目,一定考虑清楚思路,比如周期开始是不是一定是1,1(这个题目显然不是)
*再一个,要考虑到,毕竟mod 7,所以f[i]的取值有限,f[i],f[i-1]组合有限,又f[i]只与
*前两项有关,所以一定会有周期,考虑清楚这两点,题目迎刃而解
*/
#include<cstdio>
const int N = 60;//f[i]有七种取值,分别是0,1,2,3,4,5,6,那么一共C(7,1)*C(7,1)=49种"f[i],f[i-1]"组合
int main(){
  int f[N]={1,1,1};
  int a,b,n;
  int flag,beg,end;//flag标识是否找到相应周期,beg标识周期起点,end标志周期终点
  while(~scanf("%d%d%d",&a,&b,&n),a,b,n){
     flag = 1;
     for(int i=3;i<=n&&flag;i++){
        f[i]=(a*f[i-1]+b*f[i-2])%7;
        for(int j=i-1;j>=2;j--){
          if(f[i]==f[j]&&f[i-1]==f[j-1]){
             beg = j;//周期T=end-beg;
             end = i;
             flag = 0;
             break;
          }
        }
     }
     if(!flag){
       printf("%d\n",f[beg+(n-end)%(end-beg)]);
       //n>=end一定成立,(n-end)表示除去“非周期+第一个周期”后,还剩下的数,(end-beg)是周期T
     }else{
       printf("%d\n",f[n]);
     }
  }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值