N! mod 2009(数论)

WhereIsHeroFrom: Zty, what are you doing ?

Zty: I want to calculate N!..

WhereIsHeroFrom: So easy! How big N is ?

Zty: 1 <=N <=1000000000000000000000000000000000000000000000…

WhereIsHeroFrom: Oh! You must be crazy! Are you Fa Shao?

Zty: No. I haven’s finished my saying. I just said I want to calculate N! mod 2009

Hint : 0! = 1, N! = N*(N-1)!

InputEach line will contain one integer N(0 <= N<=10^9). Process to end of file.

OutputFor each case, output N! mod 2009

Sample Input
4
5
Sample Output
24
120
题意:就是求n的阶乘,取余于2009,n很大;
解题思路:由于n很大,如果只是求n的阶乘的话,那么就对运用递归调用,但是这个还得取余,那么根据推算当n为41时余数就为0,那么之后比41大的数的余数那么都得为0;

#include <iostream>
#include <cstdio>
using namespace std;
#define mod 2009
long long sove(long long n)
{
    long long ans=1;
    for(int i=2;i<=n;i++)
        ans=(ans*i)%mod;
    return ans;
}
int main()
{
    long long n;
    while(scanf("%lld",&n)!=EOF)
        {
            if(n>=mod) cout<<0<<endl;
            else cout<<sove(n)<<endl;
        }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值