最短路径(求1到各点,各点到1的距离)

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery.

The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where ‘X’ denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan.

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees.
Input
The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.
Output
For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.
Sample Input
2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50
Sample Output
46
210
题意
求1到各点,各点到1的距离
代码

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
int cnt,w[2001234],first[2001234],nextt[2001234],to[2001234];
int x[1001234],y[1001234],z[1001234],book[1001234];
void build(int x,int y,int z)
{
	nextt[cnt]=first[x];
	first[x]=cnt;
	w[cnt]=z;
	to[cnt++]=y;
}
int dis[1001234];
void dfs(int xx)
{
	memset(book,0,sizeof(book));
	memset(dis,0x3f3f3f,sizeof(dis));
	book[xx]=1;
	queue<int>q;
	q.push(xx);
	dis[xx]=0;//dis[]代表个点到xx的值 
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		book[u]=0;
		for(int i=first[u];i!=-1;i=nextt[i])
		{
			int k=to[i];
			if(dis[k]>dis[u]+w[i])
			{
				dis[k]=dis[u]+w[i];
				if(book[k]==0)//如果book[k]==0把k加进队列 
				//走到k这个点了,把它加入队列,继续往下走
				{
				book[k]=1;
				q.push(k);
				}
			}
		}
	}
}
int main()
{
	int t,i,j,n,m;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		memset(first,-1,sizeof(first));
		cnt=1;
		for(i=1;i<=m;i++)
		{
			scanf("%d%d%d",&x[i],&y[i],&z[i]);
			build(x[i],y[i],z[i]);
		}
		long long sum=0;
		dfs(1);
		for(i=1;i<=n;i++)
		sum+=dis[i];
		memset(first,-1,sizeof(first));//记得初始化first,和cnt 
		cnt=1;
		for(i=1;i<=m;i++)
		{
			build(y[i],x[i],z[i]);//反建图,求各点到1的距离 
		}
		dfs(1);
			for(i=1;i<=n;i++)
		sum+=dis[i];
		printf("%lld\n",sum);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值