W2 - Sorting

题目描述

在这里插入图片描述

Input

The input consists of several test cases and is terminated by end-of-file.
The first line of each test case contains an integer n.
The i-th of the following n lines contains 3 integers ai, bi and ci.

Output

在这里插入图片描述

Sample Input

2
1 1 1
1 1 2
2
1 1 2
1 1 1
3
1 3 1
2 2 1
3 1 1

Sample Output

2 1
1 2
1 2 3

Code

/*
 * @Description: Sorting
 * @version:
 * @Author:
 * @Date: 2021-04-06 23:23:25
 * @LastEditors: Please set LastEditors
 * @LastEditTime: 2021-04-07 15:35:39
 */
// 根据提示
#include <iostream>
#include <map>
#include <vector>
#include <algorithm>
#include <cstdio>
#include <string>
using namespace std;
typedef struct tuples tuples;
struct tuples
{
    long long a;
    long long b;
    long long c;
};

vector<pair<tuples, int>> v;
bool cmp(pair<tuples, int> A, pair<tuples, int> B)
{
    // NOTE:为防止精度问题,把除法换成乘法,要化简。看见数学公式就要想着推导
    // NOTE:还要注意排序编号,而且注意当比较的两项相等时一定要返回false。
    if (B.first.c * (A.first.a + A.first.b) < A.first.c * (B.first.a + B.first.b))
        return true;
    else if (B.first.c * (A.first.a + A.first.b) == A.first.c * (B.first.a + B.first.b))
        return A.second < B.second;
    return false;
}
int main(void)
{
    int num;
    while (scanf("%d", &num) != EOF)
    {
        v.erase(v.begin(), v.end());
        for (int i = 0; i < num; i++)
        {
            tuples temp;
            cin >> temp.a >> temp.b >> temp.c;
            v.push_back(make_pair(temp, i + 1));
        }
        sort(v.begin(), v.end(), cmp);
        for (int i = 0; i < v.size() - 1; i++)
        {
            cout << v[i].second << " ";
        }
        cout << v[v.size() - 1].second << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

jian圣楠

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值