W3 - Find The Multiple

问题描述

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

Code

/*
 * @Description: 
 * @version: 
 * @Author: 
 * @Date: 2021-04-14 14:04:42
 * @LastEditors: Please set LastEditors
 * @LastEditTime: 2021-04-14 19:08:10
 */
// self,该程序是借鉴了网络的大数计算余数的算法
#include <iostream>
#include <climits>
#include <string>
#include <queue>
using namespace std;
int n;
bool check(string str)
{
    int ans = 0;
    for (int i = 0; i < str.length(); i++)
        ans = ((ans * 10) + (str[i] - '0')) % ::n;
    if (ans == 0)
        return true;
    return false;
}
string BFS()
{
    queue<string> q;
    string temp = "1";
    q.push(temp);
    while (true)
    {
        // 如果队头字符串长度已经超过了100,则停止
        if (q.front().length() > 100)
            break;
        // 找到一个解停止
        if (check(q.front()))
            break;
        q.push(q.front() + "1");
        q.push(q.front() + "0");
        q.pop();
    }
    return q.front();
}
int main()
{
    while (cin >> n && n != 0)
    {
        cout << BFS() << endl;
    }
    system("pause");
    return 0;
}
// 提交一次
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

jian圣楠

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值