POJ 1598 Excuses, Excuses!

Judge Ito is having a problem with people subpoenaed for jury duty giving rather lame excuses in order to avoid serving. In order to reduce the amount of time required listening to goofy excuses, Judge Ito has asked that you write a program that will search for a list of keywords in a list of excuses identifying lame excuses. Keywords can be matched in an excuse regardless of case.
Input
Input to your program will consist of multiple sets of data. Line 1 of each set will contain exactly two integers. The first number (1 <= K <= 20) defines the number of keywords to be used in the search. The second number (1 <= E <= 20) defines the number of excuses in the set to be searched. Lines 2 through K+1 each contain exactly one keyword. Lines K+2 through K+1+E each contain exactly one excuse. All keywords in the keyword list will contain only contiguous lower case alphabetic characters of length L (1 <= L <= 20) and will occupy columns 1 through L in the input line. All excuses can contain any upper or lower case alphanumeric character, a space, or any of the following punctuation marks [".,!?] not including the square brackets and will not exceed 70 characters in length. Excuses will contain at least 1 non-space character.
Output
For each input set, you are to print the worst excuse(s) from the list. The worst excuse(s) is/are defined as the excuse(s) which contains the largest number of incidences of keywords. If a keyword occurs more than once in an excuse, each occurrance is considered a separate incidence. A keyword “occurs” in an excuse if and only if it exists in the string in contiguous form and is delimited by the beginning or end of the line or any non-alphabetic character or a space.

For each set of input, you are to print a single line with the number of the set immediately after the string “Excuse Set #”. (See the Sample Output). The following line(s) is/are to contain the worst excuse(s) one per line exactly as read in. If there is more than one worst excuse, you may print them in any order. After each set of output, you should print a blank line.
Sample Input
5 3
dog
ate
homework
canary
died
My dog ate my homework.
Can you believe my dog died after eating my canary… AND MY HOMEWORK?
This excuse is so good that it contain 0 keywords.
6 5
superhighway
crazy
thermonuclear
bedroom
war
building
I am having a superhighway built in my bedroom.
I am actually crazy.
1234567890…,0987654321!!!
There was a thermonuclear war!
I ate my dog, my canary, and my homework … note outdated keywords?
Sample Output
Excuse Set #1
Can you believe my dog died after eating my canary… AND MY HOMEWORK?

Excuse Set #2
I am having a superhighway built in my bedroom.
There was a thermonuclear war!
题意描述:
找出关键词出现最多的字符串并输出(如果有多个答案就按输入顺序输出)
解题思路:
将借口中的字母全部转换为小写,然后将分离出单词与关键字逐个比较,若有相符的关键词,则将记录关键字数量的变量+1。

#include <stdio.h>
#include <string.h>
#include<algorithm>
#include<iostream>
#include<string>
using namespace std;
char s[500][500];
char str[25][25];
int n,m;
int kk1(char ch[])
{
	for(int i=0; i<n; i++)
    	if(strcmp(str[i],ch)==0)
            return 1;
	return 0;        	
}
int main()
{
    int k,i,j,gta5=1;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(i=0; i<n; i++)
            scanf("%s",str[i]);
        int max=0,r=0,kk=0;
        int sum[500]={0};
        getchar();
        for(i=0;i<m;i++)
        {
            gets(s[i]);
            int len=strlen(s[i]);
            for(j=0;j<len;j++)
            {
			    k=0;
			    char ch[100];
                while(isalpha(s[i][j]))//isalpha判断是否是英文字符
                {
                	 ch[k++]=tolower(s[i][j++]);//tolower把大写转换成小写
				}
                ch[k]='\0';
                sum[i]+=kk1(ch);
				if(sum[i]>max)
	                max=sum[i];
            }
        }
        printf("Excuse Set #%d\n",gta5++);
        for(i=0;i<n;i++)
        	if(sum[i]==max)
            printf("%s\n",s[i]);
        printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

沐雨风栉

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值