AcWing 122. 糖果传递
活动地址:https://www.acwing.com/activity/content/19/
考察要点:排序 中位数 推公式 贪心
题目要求
有 n 个小朋友坐成一圈,每人有 a[i] 个糖果。
每人只能给左右两人传递糖果。
每人每次传递一个糖果代价为 1。
求使所有人获得均等糖果的最小代价。
输入格式
第一行输入一个正整数 n,表示小朋友的个数。
接下来 n 行,每行一个整数 a[i],表示第 i 个小朋友初始得到的糖果的颗数。
输出格式
输出一个整数,表示最小代价。
数据范围
1≤n≤1000000,
0≤a[i]≤2×109,
数据保证一定有解。
输入样例:
4
1
2
5
4
输出样例:
4
题目地址:https://www.acwing.com/problem/content/124/
解析:
同学们围圈而坐,交换糖果,都只能向旁边两人传递
需要列出公式进行推导
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
typedef long long LL;
const int N = 1000005;
int n; //小朋友的个数
int a[N]; //小朋友的糖果数
LL x[N]; //交换的个数
int main()
{
cin >> n;
LL sum = 0;//糖果总数
for(int i = 1; i <= n; i ++)
{
scanf("%d",&a[i]);
sum += a[i];
}
LL avg = sum / n;
for(int i = n; i > 1; i --)
{
x[i] = x[i + 1] + avg - a[i];
}
x[1] = 0;
sort(x + 1, x + n + 1); //排序
LL res = 0;
int mid = x[(n + 1) / 2]; //中位数
for(int i = 1; i <= n; i ++)
{
res += abs(x[i] - mid);
}
printf("%lld\n",res);
return 0;
}