最短路径
定义一个二维数组:
int maze[5][5] = {
0, 1, 0, 0, 0,
0, 1, 0, 1, 0,
0, 0, 0, 0, 0,
0, 1, 1, 1, 0,
0, 0, 0, 1, 0,
};
它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
简而言之就是输入一个5x5的邻接矩阵,找出最短路径并且输出路径。
思路:BFS算法
(1)从(0,0)出发,标记f数组标记是否走过且保存上一步坐标
(2)查找邻接(上下左右)可访问点,将结点加入队列p
(3)从非空队列弹出结点继续访问
(4)如果访问到终点结点,调用输出程序
AC代码:
#include<stdio.h>
#include<queue>
#include<stack>
#include<cstring>
#include<iostream>
using namespace std;
struct po{
int x;
int y;
};
int f[5][5];//标记是否走过且保存上一步坐标
int a[5][5];
int d[4][2]={{1,0},{-1,0},{0,1},{0,-1}};//左右上下
void input(po a){
stack<po> s;
po b=a;
po c;
printf("(%d, %d)\n",0,0);
while(f[b.x][b.y]!=-2){
s.push(b);//从终点倒叙将将节点压入栈
c.x=f[b.x][b.y]/10;
c.y=f[b.x][b.y]%10;
b=c;
}
while(!s.empty()){
b=s.top();
s.pop();
printf("(%d, %d)\n",b.x,b.y);
}
}
void bfs(int x,int y){
queue<po> q;
po p;
p.x=x;
p.y=y;
f[x][y]=-2;
q.push(p);
while(!q.empty()){
po old =q.front();
if(old.x==4&&old.y==4){
input(old);
break;
}
q.pop();
po now;
for(int i=0;i<4;i++){
now.x=old.x+d[i][0];
now.y=old.y+d[i][1];
if(now.x>=0&&now.y>=0&&now.x<5&&now.y<5&&a[now.x][now.y]==0&&f[now.x][now.y]==-1){
f[now.x][now.y]=old.x*10+old.y;
q.push(now);
}
}
}
}
int main(){
for(int i=0;i<5;i++){
for(int j=0;j<5;j++){
scanf("%d",&a[i][j]);
}
}
memset(f,-1,sizeof(f));
bfs(0,0);
return 0;
}