6.计蒜客ACM题库.A2011 Magic Mirror

10 篇文章 0 订阅
10 篇文章 0 订阅

计蒜客ACM题库.A2011 Magic Mirror

Jessie has a magic mirror.

Every morning she will ask the mirror: ‘Mirror mirror tell me, who is the most beautiful girl in the world?’ If the mirror says her name, she will praise the mirror: ‘Good guy!’, but if the mirror says the name of another person, she will assail the mirror: ‘Dare you say that again?’

Today Jessie asks the mirror the same question above, and you are given a series of mirror’s answers. For each answer, please output Jessie’s response. You can assume that the uppercase or lowercase letters appearing anywhere in the name will have no influence on the answer. For example, ‘Jessie’ and ‘jessie’ represent the same person.

Input
The first line contains an integer T(1≤T≤100), which is the number of test cases.

Each test case contains one line with a single-word name, which contains only English letters. The length of each name is no more than 15.

Output
For each test case, output one line containing the answer.

样例输入复制
2
Jessie
Justin
样例输出复制
Good guy!
Dare you say that again?
题目来源
ACM-ICPC 2018 焦作赛区网络预赛

答案:

#include<iostream>
using namespace std;
int main(){
	int T,i,count;
	char a[15],b[6]={'J','E','S','S','I','E'},c[6]={'j','e','s','s','i','e'};
	
	cin>>T;
	while(T--){
        a[15]={0};
		cin>>a;
		count=0;
		for(i=0;i<6;i++){
			if(a[i]==b[i]||a[i]==c[i]){
				count++;
			}
			else{
				break;
			}
		}
		if(count==6&&a[6]==0){//注意这里要求a[6]等于0,否则会导致 Jessiee 等这样的错误名字通过
			cout<<"Good guy!"<<'\n';
		}
		else{
			cout<<"Dare you say that again?"<<'\n';
		}
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值