1057 Stack (30 分)

1057 Stack (30 分)

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian – return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤105). Then N lines follow, each contains a command in one of the following 3 formats:

Push key
Pop
PeekMedian

where key is a positive integer no more than 105.

Output Specification:

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print Invalid instead.

Sample Input:

17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop

Sample Output:

Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid

题目大意:

模仿一个栈的Pop和Push操作 新添了PeekMedian操作 查询中位数

解题思路:

分块,将316个数分为一个块,首先查询中位数在哪个块里面

	int sum = 0, idx = 0;
    while (sum + block[idx] < k)sum += block[idx++];

idx为块号

然后查询该块里的具体数字

table里面存的是数字存在的次数

sum代表第几位

int num=idx*sqrtN //sqrtN=316
while(sum+table[num]<k)sum+=table[num++];

解题代码:

#include<bits/stdc++.h>
using namespace std;

stack<int> st;
const int maxn = 1e5 + 10;
const int sqrtN = 316;
int block[sqrtN], table[maxn];

void Pop()
{
	int x=st.top();
	st.pop();
	table[x]--;
    block[x / sqrtN]--;
	cout<<x<<endl;
}
void Push(int x)
{
	st.push(x);
	table[x]++;
    block[x / sqrtN]++;
}

void PeekMedian(int k)
{   
	int sum = 0, idx = 0;
    while (sum + block[idx] < k)sum += block[idx++];
    int num = sqrtN*idx;
    while (sum + table[num] < k)sum += table[num++];
    printf("%d\n", num);
}


int main()
{
	int n;
	cin>>n;
	for(int i=1;i<=n;i++)
	{
		string s;
		cin>>s;
		if(s[1]=='o')
		{
			if(st.empty())
			{
				cout<<"Invalid"<<endl;
			}
			else Pop();
		}
		else if(s[1]=='u')
		{
			int num;
			scanf("%d",&num);
			Push(num);
		}
		else if(s[1]=='e')
		{
			
			if(st.empty())
			{
				cout<<"Invalid"<<endl;
			}
			else 
			{
				int k;
                if (st.size() % 2 == 0)k = st.size() / 2;
                else k = (st.size() + 1) / 2;
                PeekMedian(k);
			}
		} 
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值