hdu 1312 Red and Black

Red and Black

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 37712 Accepted Submission(s): 22888

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

题意:

给定两个正整数W和H分别表示x方向和y方向上的瓷砖数量。W和H均不超过20.下面有H行,每行包含W个字符。每个字符表示一片瓷砖的颜色。“."表示黑色瓷砖,”#“表示红色瓷砖,”@“表示起点。
输出:一个数字,这个人从初始瓷砖能到达的瓷砖总数量(包括起点).

代码

BFS

#include<bits/stdc++.h>
using namespace std;
int dir[4][2]{
	{-1,0},
	{1,0},
	{0,-1},
	{0,1}
};//四个方向
struct node{
	int x;
	int y;
};
int Wx,Hy;
int num;
char room[23][23];
bool check(int x,int y)
{
	return (x>=0&&x<Hy&&y>=0&&y<Wx);
}//检查是否越界
void BFS(int dx,int dy)
{
	num=1;
	node start,next;
	start.x=dx;start.y=dy;
	queue<node> Q;
	Q.push(start);
	while(!Q.empty()){
		start=Q.front();
		Q.pop();
		for(int i=0;i<4;i++){
			next.x=start.x+dir[i][0];
			next.y=start.y+dir[i][1];
			if(check(next.x,next.y)&&room[next.x][next.y]=='.'){
				
				room[next.x][next.y]='#';//设置为红砖,表示已经访问过
				num++;
				Q.push(next);
			}
		}
	}
	
}
int main()
{
	int dx,dy;
	//freopen("data.txt","r",stdin);
	while(cin>>Wx>>Hy){
		if(Wx==0&&Hy==0) break;
		for(int i=0;i<Hy;i++){
			for(int j=0;j<Wx;j++){
				cin>>room[i][j];
				if(room[i][j]=='@'){
					dx=i;dy=j;
				}//起点
			}
		}
		num=0;
		BFS(dx,dy);
		cout<<num<<endl;
	}
	return 0;
} 

DFS

#include<bits/stdc++.h>
using namespace std;
int num;
int Hy,Wx;
int dir[4][2]{
	{-1,0},
	{1,0},
	{0,-1},
	{0,1}
};//四个方向
bool check(int x,int y)
{
	return (x>=0&&x<Hy&&y>=0&&y<Wx);
}//检查是否越界
char room[23][23];

void DFS(int dx,int dy)
{
	room[dx][dy]='#';
	num++;
	for(int i=0;i<4;i++){
		int newx=dx+dir[i][0];
		int newy=dy+dir[i][1];
		if(check(newx,newy)&&room[newx][newy]=='.'){
			DFS(newx,newy);
		}
	}
}
int main()
{
	int dx,dy;
	freopen("data.txt","r",stdin);
	while(cin>>Wx>>Hy){
		if(Wx==0&&Hy==0) break;
		for(int i=0;i<Hy;i++){
			for(int j=0;j<Wx;j++){
				cin>>room[i][j];
				if(room[i][j]=='@'){
					dx=i;dy=j;
				}//起点
			}
		}
		num=0;
		DFS(dx,dy);
		cout<<num<<endl;
	}
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值