hdu-2069 Coin Change(基础DP)

Coin Change

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 31856 Accepted Submission(s): 11437

Problem Description
Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.

Input
The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.

Output
For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

Sample Input
11
26

Sample Output
4
13

题意

有5种面值的硬币,即1分、5分、10分、25分、50分。输入一个钱数s,输出组合方案的数量。例如11分有4种组合方案,即11个1分,2个5分+1个1分,1个5分+6个1分,1个10分+1个1分。钱数 s<=250,硬币数量 num<=100.

分析

这是个基础DP问题,找出状态表示和状态转移方程就可以解决问题。
状态:dp[ i ][ j ] 表示用j个硬币表示钱数i的组合方案数量。
状态转移方程:dp[ i ][ j ] += dp[ i-type[] ][ j -1] (type[]为5种面值)

代码

#include<iostream>
#include<cstdio>
using namespace std;
const int COIN = 101;//硬币数量不超过100 
const int MONEY = 251;//给定钱数不超过250 
int dp[MONEY][COIN]={0};
int type[5]={1,5,10,25,50};
void solve()
{
	dp[0][0]=1;
	for(int i=0;i<5;i++){
		for(int j=1;j<COIN;j++){
			for(int k=type[i];k<MONEY;k++){
				dp[k][j] += dp[k-type[i]][j-1];
			}
		}
	}
} 
int main()
{
	int s;
	int ans[MONEY]={0};
	solve();//用DP计算完整的转移矩阵 
	for(int i=0;i<MONEY;i++){//对每个金额计算有多少种组合方案,打表 
		for(int j=0;j<COIN;j++){
			ans[i] += dp[i][j];
		}
	} 
	while(~scanf("%d",&s)){
		printf("%d\n",ans[s]);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值