实验:VRRP-浮动路由

在这里插入图片描述

内容要点:

  1. 浮动路由
  2. VRRP

注意事项

  1. 浮动路由默认是优先级是 60,越小越优先,如果是第二条路由优先级是比默认的要大,一般配置60以上。
  2. VRRP : (公有协议)
    在多个路由器之间运行,可以虚拟出一个或者多个网关IP地址(虚拟路由器);从而实现内网不同网段之间的互通;
  3. VRRP的工作过程:
    运行VRRP的“多个”路由器之间通过 VRRP 报文的交互,从而选择出一个最牛的路由器,作为 Msater 路由器,以后就用这个设备来转发数据包;
    Master 路由器,仅仅只有一个
    其他的路由器称为 backup 路由器;
    同时, Master 和 Backup 路由器,会产生一个虚拟的路由器,也就是一个虚拟的IP地址。

LSW1配置:

1. 创建vlan

vlan batch 10 20			        //划分VLAN 10 20 

2. E0/0/1和E0/0/2的接口配置:

interface Ethernet0/0/1                         //配置e0/0/1为Access口,VLAN10
 port link-type access
 port default vlan 10
interface Ethernet0/0/2                         //配置e0/0/2为Access口,VLAN20
 port link-type access
 port default vlan 20

3. G0/0/1和G0/0/2的接口配置:

interface GigabitEthernet0/0/1                  //配置g0/0/1为Trunk口,只允许VLAN10 VLAN20流量过
 port link-type trunk
 port trunk allow-pass vlan 10 20
interface GigabitEthernet0/0/2                  //配置g0/0/2为Trunk口,只允许VLAN10 VLAN20流量过
 port link-type trunk
 port trunk allow-pass vlan 10 20

LSW2配置:

1. 创建vlan

vlan batch 10 20 100

2. vlan10、vlan20 和 vlan100 的三层接口配置:

interface Vlanif10                                               //划分VLAN 10 20 100
 ip address 192.168.10.10 255.255.255.0
 vrrp vrid 1 virtual-ip 192.168.10.1                             //配置虚拟IP地址
 vrrp vrid 1 priority 120                                        //配置优先级120
 vrrp vrid 1 track interface GigabitEthernet0/0/1     //配置监听端口g0/0/1,当这个地方down 优先级减10
 vrrp vrid 1 track interface GigabitEthernet0/0/2     //配置监听端口g0/0/2,当这个地方down 优先级减10
interface Vlanif20
 ip address 192.168.20.10 255.255.255.0
 vrrp vrid 2 virtual-ip 192.168.20.1                              //配置虚拟IP地址
 vrrp vrid 2 priority 115                                         //配置优先级115
interface Vlanif100
 ip address 11.0.0.2 255.255.255.252

3. G0/0/1和G0/0/2的接口配置:

interface GigabitEthernet0/0/1                                   // 配置g0/0/1为Access口,VLAN100
undo shutdown
port link-type access
port default vlan 100
interface GigabitEthernet0/0/2                      //配置g0/0/1为Trunk口,只允许VLAN10 VLAN20流量过
port link-type trunk
port trunk allow-pass vlan 10 20
undo shutdown

4. 设置默认路由

ip route-static 0.0.0.0 0.0.0.0 11.0.0.1

LSW3配置:

1. 创建vlan

vlan batch 10 20 100						  //划分VLAN 10 20 100

2. vlan10、vlan20 和 vlan100 的三层接口配置:

interface Vlanif10
ip address 192.168.10.20 255.255.255.0
vrrp vrid 1 virtual-ip 192.168.10.1          			  //配置虚拟IP地址
vrrp vrid 1 priority 115				          //配置优先级115
interface Vlanif20
 ip address 192.168.20.20 255.255.255.0
 vrrp vrid 2 virtual-ip 192.168.20.1		   		  //配置虚拟IP地址
 vrrp vrid 2 priority 120					  //配置优先级120
 vrrp vrid 2 track interface GigabitEthernet0/0/1     //配置监听端口g0/0/1,当这个地方down 优先级减10
 vrrp vrid 2 track interface GigabitEthernet0/0/2     //配置监听端口g0/0/2,当这个地方down 优先级减10
interface Vlanif100
ip address 12.0.0.2 255.255.255.252

3. G0/0/1和G0/0/2的接口配置:

interface GigabitEthernet0/0/1
port link-type access
port default vlan 100
undo shutdown
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 10 20
undo shutdown

4. 设置默认路由

ip route-static 0.0.0.0 0.0.0.0 12.0.0.1

R1配置:

1. G0/0/0和G0/0/1的接口配置

interface GigabitEthernet0/0/0
 ip address 11.0.0.1 255.255.255.252
interface GigabitEthernet0/0/1
 ip address 12.0.0.1 255.255.255.252

2. 设置环回口

interface LoopBack0
 ip address 1.1.1.1 255.255.255.0

3. 配置路由:(浮动+静态)

ip route-static 192.168.10.0 255.255.255.0 11.0.0.2				//静态
ip route-static 192.168.10.0 255.255.255.0 12.0.0.2 preference 70		//浮动
ip route-static 192.168.20.0 255.255.255.0 12.0.0.2
ip route-static 192.168.20.0 255.255.255.0 11.0.0.2 preference 70

手动设置PC的IP配置:

在这里插入图片描述

数据传输测试是否良好

在这里插入图片描述

抓包检验浮动路线是否通行

进入LSW2

int g0/0/1                                                        //进入接口
shutdown                                                       //关闭接口

在int g0/0/2接口处开始抓包在这里插入图片描述
抢占完成数据就开始从浮动路线开始传输数据。

展开阅读全文
©️2020 CSDN 皮肤主题: 游动-白 设计师: 上身试试 返回首页
实付0元
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值