Java PTA练习:jmu-Java-03面向对象基础-04-形状-继承

前言

前面题目形状中我们看到,为了输出所有形状的周长与面积,需要建立多个数组进行多次循环。这次试验使用继承与多态来改进我们的设计。

本题描述

1.定义抽象类Shape
属性:不可变静态常量double PI,值为3.14
抽象方法:public double getPerimeter(),public double getArea()

2.RectangleCircle类均继承自Shape类。
Rectangle类(属性:int width,length)、Circle类(属性:int radius)。
带参构造方法为Rectangle(int width,int length),Circle(int radius)
toString方法(Eclipse自动生成)

3.编写double sumAllArea方法计算并返回传入的形状数组中所有对象的面积和
double sumAllPerimeter方法计算并返回传入的形状数组中所有对象的周长和

4.main方法
4.1 输入整型值n,然后建立n个不同的形状。如果输入rect,则依次输入宽、长。如果输入cir,则输入半径。
4.2 然后输出所有的形状的周长之和,面积之和。并将所有的形状信息以样例的格式输出。 提示:使用Arrays.toString
4.3 最后输出每个形状的类型与父类型.使用类似shape.getClass() //获得类型, shape.getClass().getSuperclass() //获得父类型;

注意:处理输入的时候使用混合使用nextIntnextLine需注意行尾回车换行问题。

思考

  1. 你觉得sumAllArea和sumAllPerimeter方法放在哪个类中更合适?
  2. 是否应该声明为static?

输入样例:

4
rect
3 1
rect
1 5
cir
1
cir
2

输出样例:

38.84
23.700000000000003
[Rectangle [width=3, length=1], Rectangle [width=1, length=5], Circle [radius=1], Circle [radius=2]]
class Rectangle,class Shape
class Rectangle,class Shape
class Circle,class Shape
class Circle,class Shape

代码示例:

import java.util.*;

abstract class Shape{
	static final double PI = 3.14;
	public abstract double getPerimeter();
	public abstract double getArea();
}

class Rectangle extends Shape{
	private int width;
	private int length;
	public Rectangle(int width,int length) {
		this.width = width;
		this.length = length;
	}
	public double getPerimeter() {
		return 2*(this.width+this.length);
	}
	public double getArea() {
		return this.width*this.length;
	}
	@Override
	public String toString() {
		return "Rectangle [width=" + width + ", length=" + length + "]";
	}
}

class Circle extends Shape{
	private int radius;
	public Circle(int radius) {
		this.radius = radius;
	}
	public double getPerimeter() {
		return PI*this.radius*2;
	}
	public double getArea() {
		return PI*this.radius*this.radius;
	}
	@Override
	public String toString() {
		return "Circle [radius=" + radius + "]";
	}
}

public class Main{
    public static void main(String [] args){
    	Scanner in=new Scanner(System.in);
    	int n = in.nextInt();
    	in.nextLine();
    	Shape [] shapes = new Shape[n];
    	for(int i=0;i<n;i++){
    		String shape = in.nextLine();
    		if(shape.equals("rect")) {
    			int width = in.nextInt();
    			int length = in.nextInt();
    			in.nextLine(
    					);
    			shapes[i] = new Rectangle(width, length);
    		}
    		else {
    			int radius = in.nextInt();
    			in.nextLine();
    			shapes[i] = new Circle(radius);
    		}
    	}
    	System.out.println(sumAllPerimeter(shapes));
    	System.out.println(sumAllArea(shapes));
    	System.out.println(Arrays.toString(shapes));
    	for(Shape s:shapes) {
    		System.out.println(s.getClass()+","+s.getClass().getSuperclass());
    	}
    }
    public static double sumAllArea(Shape[] shapes) {
    	double sum = 0;
    	
    	for(Shape s:shapes) {
    		sum+=s.getArea();
    	}
    	return sum;
    }
    public static double sumAllPerimeter(Shape[] shapes) {
    	double sum = 0;
    	
    	for(Shape s:shapes) {
    		sum+=s.getPerimeter();
    	}
    	return sum;
    }
}

  • 3
    点赞
  • 19
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值