1028 List Sorting (25 分) java 题解

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤105) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 9

Sample Output 3:

000002 James 9
000001 Zoe 60
000007 James 85
000010 Amy 90

题目描述:

将一些学生信息按其不同属性选择性的排序。

解题思路:

将学生信息封装到类,按排序类别利用Compator比较器实现定制排序。

java代码:

import java.io.*;
import java.util.*;

public class Main {
	public static void main(String[] args) throws IOException {
		BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
		String[] split = br.readLine().split(" ");
		int n = Integer.parseInt(split[0]);
		int type = Integer.parseInt(split[1]);
		List<Student1028> list = new ArrayList<>();
		for(int i = 0; i < n;i++) {
			split = br.readLine().split(" ");
			String id = split[0];
			String name = split[1];
			int grade = Integer.parseInt(split[2]);
			list.add(new Student1028(id, name, grade));
		}
		if(type == 1) {
			Collections.sort(list, new Comparator<Student1028>() {
				@Override
				public int compare(Student1028 o1, Student1028 o2) {
					return o1.id.compareTo(o2.id);
				}
			});
		}else if(type == 2) {
			Collections.sort(list, new Comparator<Student1028>() {
				@Override
				public int compare(Student1028 o1, Student1028 o2) {
					if(!o1.name.equals(o2.name)) {
						return o1.name.compareTo(o2.name);
					}else {
						return o1.id.compareTo(o2.id);
					}
				}
			});
		}else {
			Collections.sort(list, new Comparator<Student1028>() {
				@Override
				public int compare(Student1028 o1, Student1028 o2) {
					if(o1.grade != o2.grade) {
						return o1.grade - o2.grade;
					}else {
						return o1.id.compareTo(o2.id);
					}
				}
			});
		}
		StringBuilder builder = new StringBuilder();
		for(Student1028 data : list) {
//			System.out.print(data);
			builder.append(data);
		}
		System.out.print(builder.toString());
	}
}
class Student1028{
	String id;
	String name;
	int grade;
	
	public Student1028(String id, String name, int grade) {
		this.id = id;
		this.name = name;
		this.grade = grade;
	}

	@Override
	public String toString() {
		return id + " " + name + " " + grade + "\n";
	}
}

PTA提交截图:

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值