PAT (Advanced Level) Practice - 1051 Pop Sequence

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:
YES
NO
NO
YES
NO

//已知入栈 出栈序列 模拟一遍栈的操作 两个序列都能走完就代表成功 否则失败

#include <stdio.h>
int main(){
    int m,n,k,i,j;
    scanf("%d %d %d",&m,&n,&k);
    //stack为模拟栈 top为栈顶
    //push为入栈顺序 p为下标
    //pop为出栈顺序 q为下标
    int stack[m],top,push[n+1],p,q;
    for(i=1;i<=n;i++) push[i]=i;    
    for(i=0;i<k;i++){
        int pop[n+1];
        for(j=1;j<=n;j++) scanf("%d",&pop[j]);
        p=q=1;  //每轮初始为1
        top=0;  //每轮初始为0
        while(1){
            //栈空或栈顶元素不是下个出栈元素 且栈未满 且入栈序列还有元素 则入栈
            while((top==0 || stack[top-1]!=pop[q]) && top<m && p<=n) stack[top++]=push[p++];
            //此时栈顶为下个出栈元素 开始循环判断出栈
            if(stack[top-1]==pop[q]){
                while(top>0 && q<=n && stack[top-1]==pop[q]){
                    top--;
                    q++;
                }
            }
            else{   //若此时栈顶不是下个出栈元素 那么此时必定为栈满 或 入栈队序列为空 代表无解
                printf("NO\n");
                break;
            }
            if(p>n && q>n){     //入栈序列 出栈序列 均已完毕
                printf("YES\n");
                break;
            }
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值