Swap(二分图最大匹配)

题目

Given an NN matrix with each entry equal to 0 or 1. You can swap any two rows or any two columns. Can you find a way to make all the diagonal entries equal to 1?
Input
There are several test cases in the input. The first line of each test case is an integer N (1 <= N <= 100). Then N lines follow, each contains N numbers (0 or 1), separating by space, indicating the N
N matrix.
Output
For each test case, the first line contain the number of swaps M. Then M lines follow, whose format is “R a b” or “C a b”, indicating swapping the row a and row b, or swapping the column a and column b. (1 <= a, b <= N). Any correct answer will be accepted, but M should be more than 1000.

If it is impossible to make all the diagonal entries equal to 1, output only one one containing “-1”.
Sample Input
2
0 1
1 0
2
1 0
1 0
Sample Output
1
R 1 2
-1

题意

问能不能通过交换行或者列,使主对角线上的数全为1

思路

没思路。首先看1的个数够不够使对角线上的元素全为1,如果不够直接输出-1,然后找到这一行(或者列)是跟哪一列(行)匹配的,把第一个列与第二列交换,此时(1,1)的位置就是1了,
比如
0 1 0
1 0 1
0 1 0
把第一个列与第二列交换,此时(1,1)的位置就是1了,
现在第一行就是跟第二列匹配的
1 0 0
0 1 1
1 0 0
此时发现第三行没有与之对应的,就没办法使对角线全为1了,输出-1即可

代码

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int book[101001],match[10100],e[1010][1010];
int x[1010],y[1001],n;
int dfs(int u)
{
	for(int i=1; i<=n; i++)
	{
		if(!book[i]&&e[u][i])
		{
			book[i]=1;
			if(dfs(match[i])||!match[i])
			{
				match[i]=u;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int i,j,k,m;
	while(~scanf("%d",&n))
	{
		memset(x,0,sizeof(x));
		memset(y,0,sizeof(y));
		memset(match,0,sizeof(match));
		memset(e,0,sizeof(e));
		for(i=1; i<=n; i++)
		{
			for(j=1; j<=n; j++)
				scanf("%d",&e[i][j]);
		}
		int sum=0;
		for(i=1; i<=n; i++)
		{
			memset(book,0,sizeof(book));
			if(dfs(i))
				sum++;
		}
		if(sum<n)
		{
			printf("-1\n");
			continue;//不能每一行至少配对一个
		}
		int r=0;
		for(i=1; i<=n; i++)
		{
			if(i!=match[i])
			{
				for(j=1; j<=n; j++)
				{
					if(i==match[j])
					{
						x[r]=i;
						y[r]=j;
						r++;
//				int t;
//				t=match[x[r]];
//				match[x[r]]=match[y[r]];
//				match[y[r]]=t;
						swap(match[i],match[j]);//交换这两列
						break;
					}


//				      printf("*** %d %d\n",i,match[i]);
				}

			}
		}
		printf("%d\n",r);
		for(i=0; i<r; i++)
		{
			printf("C %d %d\n",x[i],y[i]);
		}
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值