7-2 Subsequence in Substring分数 25

substring is a continuous part of a string. A subsequence is the part of a string that might be continuous or not but the order of the elements is maintained. For example, given the string atpaaabpabttpabt is a substring, while pat is a subsequence.

Now given a string S and a subsequence P, you are supposed to find the shortest substring of S that contains P. If such a solution is not unique, output the left most one.

Input Specification:

Each input file contains one test case which consists of two lines. The first line contains S and the second line P. S is non-empty and consists of no more than 104 lower English letters. P is guaranteed to be a non-empty subsequence of S.

Output Specification:

For each case, print the shortest substring of S that contains P. If such a solution is not unique, output the left most one.

Sample Input:

atpaaabpabttpcat
pat

Sample Output:

pabt
#include<iostream>
using namespace std;
string s,p;
int min_start,min_len;
void dfs(int j,int i,int s_start){
    if(j==p.size()){
        if(min_len>i-s_start){
            min_len = i-s_start;
            min_start = s_start;
        }
        return;
    }
    if(i>=s.size()||i-s_start>=min_len)return;
    while(i<s.size()&&s[i]!=p[j])i++;
    if(i<s.size()){
        dfs(j+1,i+1,s_start);
    }
}
int main(){
    cin>>s>>p;
    int l,r;
    int start = 0;
    min_len =s.size()+1;
    for(start = 0;start+p.size()<s.size();start++){
        if(s[start]==p[0]) dfs(1,start+1,start);
    }
    cout<<s.substr(min_start,min_len)<<endl;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值