7-1 The Closest Fibonacci Number

The Fibonacci sequence Fn​ is defined by Fn+2​=Fn+1​+Fn​ for n≥0, with F0​=0 and F1​=1. The closest Fibonacci number is defined as the Fibonacci number with the smallest absolute difference with the given integer N.

Your job is to find the closest Fibonacci number for any given N.

Input Specification:

Each input file contains one test case, which gives a positive integer N (≤108).

Output Specification:

For each case, print the closest Fibonacci number. If the solution is not unique, output the smallest one.

Sample Input:

305

Sample Output:

233

Hint:

Since part of the sequence is { 0, 1, 1, 2, 3, 5, 8, 12, 21, 34, 55, 89, 144, 233, 377, 610, ... }, there are two solutions: 233 and 377, both have the smallest distance 72 to 305. The smaller one must be printed out.

#include<iostream>
using namespace std;
const int N = 1000010;
int f[N];
int fib(int n){
    f[0] = 0,f[1] = 1;
    int i = 1;
    for(i = 2;;i++){
        f[i] = f[i-1]+f[i-2];
        if(f[i]>=n)break;
    }
    return i;
}
int main(){
    int n;
    scanf("%d",&n);
    int k = fib(n);
    int n1 = 0x3f3f3f3f,n2 = 0x3f3f3f3f;
    if(k>0) n1 = abs(f[k-1]-n);
    n2 = abs(f[k]-n);
    if(n1<=n2) printf("%d",f[k-1]);
    else printf("%d",f[k]);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值