1165 Block Reversing分数 25

Given a singly linked list L. Let us consider every K nodes as a block (if there are less than K nodes at the end of the list, the rest of the nodes are still considered as a block). Your job is to reverse all the blocks in L. For example, given L as 1→2→3→4→5→6→7→8 and K as 3, your output must be 7→8→4→5→6→1→2→3.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤105) which is the total number of nodes, and a positive K (≤N) which is the size of a block. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 8 3
71120 7 88666
00000 4 99999
00100 1 12309
68237 6 71120
33218 3 00000
99999 5 68237
88666 8 -1
12309 2 33218

Sample Output:

71120 7 88666
88666 8 00000
00000 4 99999
99999 5 68237
68237 6 00100
00100 1 12309
12309 2 33218
33218 3 -1
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
const int N = 100010;
int ne[N],e[N];
int n,k;
int main(){
    int h;
    scanf("%d %d %d",&h,&n,&k);
    for(int i = 0;i<n;i++){
        int address,data,next;scanf("%d %d %d",&address,&data,&next);
        ne[address] = next;
        e[address] = data;
    }
    vector<int> v;
    for(int i = h;~i;i=ne[i]){
        v.push_back(i);
    }
    reverse(v.begin(),v.end());
    int s = v.size();
    for(int i = 0;i<s;){
        if(!i&&s%k!=0){
             int len = s%k;
             reverse(v.begin()+i,v.begin()+i+min(len,s));
             i+=len;
        }else{
             reverse(v.begin()+i,v.begin()+i+min(k,s));
             i+=k;
        }
     }
    for(int i = 0;i<s;i++){
        printf("%05d %d",v[i],e[v[i]]);
        if(i==s-1) printf(" -1\n");
        else printf(" %05d\n",v[i+1]);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值