1165 Block Reversing (25 point(s)) PAT甲级

1165 Block Reversing (25 point(s))

题目

Given a singly linked list L. Let us consider every K nodes as a block (if there are less than K nodes at the end of the list, the rest of the nodes are still considered as a block). Your job is to reverse all the blocks in L. For example, given L as 1→2→3→4→5→6→7→8 and K as 3, your output must be 7→8→4→5→6→1→2→3.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤105) which is the total number of nodes, and a positive K (≤N) which is the size of a block. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 8 3
71120 7 88666
00000 4 99999
00100 1 12309
68237 6 71120
33218 3 00000
99999 5 68237
88666 8 -1
12309 2 33218

Sample Output:

71120 7 88666
88666 8 00000
00000 4 99999
99999 5 68237
68237 6 00100
00100 1 12309
12309 2 33218
33218 3 -1

思路

题意

读入一串字符,共n个数字,按照k个一组分组(最后不足k个的数的数字单独成组)。以组为单位倒序输出链表。

思路

用map记录每个数字的地址和下一个结点的地址。遍历链表(这里注意给的inpu数据可能有链表之外的脏数据,不能按照n个数字遍历),记录每组的第一个数据地址到ans队列中。倒序输出ans队列每组地址的数据,注意收尾分别处理即可。

解法

#include<bits/stdc++.h>
using namespace std;

int n, k;
int start;

struct node
{
	int data;
	int next;
};

int main() {
	scanf("%d%d%d", &start, &n, &k);
	map<int, node> numbers;//记录每个地址的数字和下一个地址
	vector<int> ans;
	for (int i = 0; i < n; ++i) {
		int ad;
		scanf("%d", &ad);
		scanf("%d%d", &(numbers[ad].data), &(numbers[ad].next));
	}
	int temp = start, index = 0;
	while (temp != -1) {//不能直接用n个数据遍历,最后一个结点有脏数据会过不去
		if (index % k == 0) ans.push_back(temp);//ans存每个block的起始地址
		temp = numbers[temp].next;
		index++;
	}
	temp = ans[ans.size() - 1];
	printf("%05d ", temp);
	while (numbers[temp].next != -1) {//先输出最后一个block,因为数字可能不是k单独处理
		printf("%d %05d\n%05d ", numbers[temp].data, numbers[temp].next, numbers[temp].next);
		temp = numbers[temp].next;
	}
	for (int i = ans.size() - 2; i >= 0; i--) {//其他block的处理方式
		printf("%d ", numbers[temp].data);
		temp = ans[i];
		printf("%05d\n%05d ", temp, temp);
		for (int j = 0; j < k - 1; j++) {
			printf("%d %05d\n%05d ", numbers[temp].data, numbers[temp].next, numbers[temp].next);
			temp = numbers[temp].next;
		}
	}
	printf("%d %d\n", numbers[temp].data, -1);//最后一个-1输出格式不同,单独输出
	return 0;
}

注意

  • 考虑输入中存在脏数据的情况
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值