PAT 1008 Elevator

本文介绍了PAT编程竞赛中的一道题目——1008 Elevator,探讨了如何计算满足请求列表所需的总时间。题目要求电梯从0层开始,不返回地面,每个楼层停留5秒。解决方案涉及上升、下降和停留时间的计算,特别是考虑了连续两次在同一楼层的情况。代码已给出并成功通过测试。
摘要由CSDN通过智能技术生成

1008 Elevator

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

 总结:一开始还以为这题目很难,但是仔细的看了看,还是很简单的,就是简单的循环计算

注意:当连续两个request都在同一层的时候,是需要停留两次的,也就是说,当前层和上一次需求的层是由三种情况的

①:在上一次需求层的上面        电梯上升时间+停留时间

②下面        电梯下降时间+停留时间

③当前层        停留时间

代码(从第一题到现在第一次AC  T^T):

#include <iostream>
using namespace std;

const int N=110;
int a[N];
int n;

int main(){
    cin >> n;
    
    for(int i=0;i<n;i++)    scanf("%d",&a[i]);
    
    int t=0,f=0;
    for(int i=0;i<n;i++){
        if(a[i]>f)  t+=(a[i]-f)*6;
        else if(a[i]<f) t-=(a[i]-f)*4;
        t+=5;
        f=a[i];
    }
    
    printf("%d\n",t);
    
    return 0;
}

好好学习,天天向上!

我要考研!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值