PAT 1024 Palindromic Number(高精度加法)

1024 Palindromic Number

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤1010) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

总结:这题还是比较简单的,没太大的难度,直接模拟过程就可以,两个数相加使用高精度加法计算,翻转使用 algorithm 头文件的 reverse 函数即可,一开始写的时候直接用的 int 相加,这就导致了运行时出错,是因为爆 int 了,加入 n 是一个 10^9 的数,k=100,那么会超出 int 的表示范围

代码:

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;

vector<int> add(vector<int> &a,vector<int> &b){
    vector<int> c;
    int t=0;
    
    for(int i=0;i<a.size();i++){
        t+=a[i]+b[i];
        c.push_back(t%10);
        if(t>=10)   t=1;
        else t=0;
    }
    
    if(t)   c.push_back(1);
    return c;
}

int main(){
    int k,cot=0;
    string n,t;
    cin >> n >> k;
    
    while(cot<k){
        string s;
        t=n;
        reverse(t.begin(),t.end());
        if(t==n)    break;//比较是否是回文数字
        
        vector<int> a,b;//将两个数的每个数字都用vector存储起来进行加法运算
        for(int i=n.size()-1;i>=0;i--)  a.push_back(n[i]-'0');
        for(int i=t.size()-1;i>=0;i--)  b.push_back(t[i]-'0');
        
        auto c=add(a,b);
        
        for(int i=c.size()-1;i>=0;i--)  s+=(c[i]+'0');
        n=s;
        cot++;
    }
    
    cout << n << endl << cot << endl;
    
    return 0;
}

依照惯例,还是看看大佬的代码!

还是依旧的那么简短、易懂!

学习:直接使用 string 做大运算!

#include <iostream>
#include <algorithm>
using namespace std;

string s;
void add(string t){
    int c=0;
    //低位存高位的值,如果没有进位的话,其实算出来的结果都是对称的,但是有了进位可能不对称
    //有进位就会把进位往高位偏移,加上最后一个进位,然后反转就是正常的顺序了
    for(int i=0;i<s.size();i++){
        s[i]=s[i]+t[i]+c-'0';
        c=0;
        if(s[i]>'9'){
            s[i]-=10;
            c=1;
        }
    }
    if(c)   s+='1';
    reverse(s.begin(),s.end());
}

int main(){
    int k,cot=0;
    cin >> s >> k;
    
    while(cot<k){
        string t=s;
        reverse(t.begin(),t.end());
        if(s==t)    break;
        
        add(t);
        cot++;
    }
    
    cout << s << endl << cot << endl;
    
    return 0;
}

好好学习,天天向上!

我要考研!

2022.11.2

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

vector<int> add(vector<int> &a,vector<int> &b){
    vector<int> c;
    int t=0;
    
    for(int i=0;i<a.size();i++){
        t+=a[i]+b[i];
        c.push_back(t%10);
        t/=10;
    }
    if(t)   c.push_back(1);
    return c;
}
bool judge(vector<int> &a){
    for(int i=0;i<a.size()/2;i++)
        if(a[i]!=a[a.size()-i-1])   return false;
    return true;
}
int main(){
    string s;
    int k,cot=0;
    cin >> s >> k;
    vector<int> a;

    for(int i=s.size()-1;i>=0;i--)  a.push_back(s[i]-'0');
    
    while(cot<k){
        if(judge(a)){
            for(int i=a.size()-1;i>=0;i--)  printf("%d",a[i]);
            printf("\n%d\n",cot);
            return 0;
        }
        vector<int> b(a);
        for(int i=0;i<b.size();i++) b[i]=a[a.size()-1-i];
        auto c=add(a,b);
        a=c;
        cot++;
    }
    for(int i=a.size()-1;i>=0;i--)  printf("%d",a[i]);
    printf("\n%d\n",cot);
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值