PAT 1028 List Sorting

1028 List Sorting

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤105) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 9

Sample Output 3:

000002 James 9
000001 Zoe 60
000007 James 85
000010 Amy 90

总结:这题没有什么难度,写出结果cmp函数就行了(注意,在写cmp函数的时候,还是严谨点,因为题目说的是非降序,在cmp2,3中后面那个比较不要直接<,应该<=)

#include <iostream>
#include <algorithm>
using namespace std;

struct peo{
    int id,score;
    string name;
}s[100010];

//id排名升序
bool cmp1(peo a,peo b){
    return a.id<b.id;
}

bool cmp2(peo a,peo b){
    return a.name==b.name?a.id<b.id:a.name<b.name;
}

bool cmp3(peo a,peo b){
    return a.score==b.score?a.id<b.id:a.score<b.score;
}

int main(){
    int n,c;
    cin >> n >> c;
    
    for(int i=0;i<n;i++){
        cin >> s[i].id >> s[i].name >> s[i].score;
    }
    
    if(c==1)    sort(s,s+n,cmp1);
    else if(c==2)   sort(s,s+n,cmp2);
    else sort(s,s+n,cmp3);
    
    for(int i=0;i<n;i++){
        printf("%06d ",s[i].id);
        cout << s[i].name << ' ' << s[i].score << endl;
    }
    
    return 0;
}

 依照惯例,看看大佬的代码:

可以学习一下在cmp函数内部使用if判断是哪种情况的代码!

#include <iostream>
#include <algorithm>
#include <string.h>
using namespace std;
const int maxn = 100001;
struct NODE {
    int no, score;
    char name[10];
}node[maxn];
int c;
int cmp1(NODE a, NODE b) {
    if(c == 1) {
        return a.no < b.no;
    } else if(c == 2) {
        if(strcmp(a.name, b.name) == 0) return a.no < b.no;
        return strcmp(a.name, b.name) <= 0;
    } else {
        if(a.score == b.score) return a.no < b.no;
        return a.score <= b.score;
    }
}
int main() {
    int n;
    scanf("%d%d", &n, &c);
    for(int i = 0; i < n; i++)
        scanf("%d %s %d", &node[i].no, node[i].name, &node[i].score);
    sort(node, node + n, cmp1);
    for(int i = 0; i < n; i++)
        printf("%06d %s %d\n", node[i].no, node[i].name, node[i].score);
    return 0;
}

好好学习,天天向上!

我要考研!

2022.11.2

#include <iostream>
#include <algorithm>
#include <cstring>
#include <vector>
using namespace std;

struct student{
    int id;
    char name[10];
    int grade;
};
int c,n;
bool cmp(student a,student b){
    if(c==1)    return a.id<b.id;
    //strcmp返回值如果小于1,则说明 str1 小于 str2
    else if(c==2 && a.name!=b.name) return strcmp(a.name,b.name)<=0;
    else if(c==3 && a.grade!=b.grade)   return a.grade<b.grade;
    return a.id<b.id;
}
int main(){
    scanf("%d%d",&n,&c);
    vector<student> s(n);
    
    for(int i=0;i<n;i++)    
        scanf("%d %s %d",&s[i].id,s[i].name,&s[i].grade);
    sort(s.begin(),s.end(),cmp);
    
    for(int i=0;i<n;i++)
        printf("%06d %s %d\n",s[i].id,s[i].name,s[i].grade);
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值