PAT 1031 Hello World for U

1031 Hello World for U

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1​ characters, then left to right along the bottom line with n2​ characters, and finally bottom-up along the vertical line with n3​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1​=n3​=max { k | k≤n2​ for all 3≤n2​≤N } with n1​+n2​+n3​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

总结:这道题写的不行,不知道哪里错了,两个测点没过

知道了,原来是一开始在余数为2的情况下n1,n2,n3的值分错了,没正确理解题目意思,n1,n3是永远都要小于n2的,所以当余数为2时,多余的两个都分给n2

#include <iostream>
using namespace std;

int main(){
    string s,t;
    int n1,n2,n3,n;
    cin >> s;
    
    n=(s.size()+2)/3;
    if((s.size()+2)%3==0)   n1=n2=n3=n;
    else if((s.size()+2)%3==1){
        n1=n3=n;
        n2=n+1;
    }
    else{
        n1=n3=n+1;
        n2=n;
    }

    for(int i=0;i<n1-1;i++){
        t+=s[i];
        t+=s[s.size()-1-i];
    }
    t+=s.substr(n1-1,n2);
    
    int index=0;
    for(int i=0;i<n1-1;i++){
        for(int j=0;j<n2;j++){
            if(j==0 || j==n2-1) cout << t[index++];
            else cout << ' ';
        }
        cout << endl;
    }
    cout << s.substr(n1-1,n2) << endl;
    
    return 0;
}

 依照惯例,还是看看大佬的代码:

膜拜,真的是长见识了!

#include <iostream>
#include <string.h>
using namespace std;
int main() {
    char c[81], u[30][30];
    memset(u, ' ', sizeof(u));
    scanf("%s", c);
    int n = strlen(c) + 2;
    int n1 = n / 3, n2 = n / 3 + n % 3, index = 0;
    for(int i = 0; i < n1; i++) u[i][0] = c[index++];
    for(int i = 1; i <= n2 - 2; i++) u[n1-1][i] = c[index++];
    for(int i = n1 - 1; i >= 0; i--) u[i][n2-1] = c[index++];
    for(int i = 0; i < n1; i++) {
        for(int j = 0; j < n2; j++) 
            printf("%c", u[i][j]);
        printf("\n");
    }
    return 0;
}

好好学习,天天向上!

我要考研!

2022.11.3

开始没有看清楚题目,题目中说的n1=最顶端到最底端的字符的数量

#include <iostream>
using namespace std;

int main(){
    string s;
    cin >> s;
    
    int n,n1,n2,n3;
    n=(s.size()+2)/3;
    n1=n3=n;//从最顶端到最低端字符的数量
    n2=s.size()-n1*2;//求出来的是中间空格的数量
    for(int i=0;i<n1-1;i++){
        printf("%c",s[i]);
        for(int j=0;j<n2;j++) printf(" ");
        printf("%c\n",s[s.size()-1-i]);
    }
    for(int i=n1-1;i<n1+n2+1;i++)   printf("%c",s[i]);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值