PAT 1080 Graduate Admission

1080 Graduate Admission

It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.

Each applicant will have to provide two grades: the national entrance exam grade GE​, and the interview grade GI​. The final grade of an applicant is (GE​+GI​)/2. The admission rules are:

  • The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.

  • If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade GE​. If still tied, their ranks must be the same.

  • Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one's turn to be admitted; and if the quota of one's most preferred shcool is not exceeded, then one will be admitted to this school, or one's other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.

  • If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

Input Specification:

Each input file contains one test case.

Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.

In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.

Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant's GE​ and GI​, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M−1, and the applicants are numbered from 0 to N−1.

Output Specification:

For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants' numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

Sample Input:

11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4

Sample Output:

0 10
3
5 6 7
2 8

1 4

 总结:这道题目前前后后写了挺久的(一个半小时~两个小时,在真正的考试当中肯定是没有这么多的时间的,需要多写写,好好总结,加快写代码的速度)

代码:

#include <iostream>
#include <map>  //用来存储学校录取学生的序号
#include <algorithm>
#include <vector>
using namespace std;

typedef pair<int,int> PII;
struct stu{
    int ge,gi,rank,id;
    int s[10];
};
int n,m,k;
vector<stu> v(40010);
vector<vector<PII>> q;//存储学校招生的人数和最近招收学生的排名
bool cmp(stu a,stu b){
    if(a.ge+a.gi!=b.ge+b.gi)    return a.ge+a.gi>b.ge+b.gi;
    else return a.ge>b.ge;
}
bool cmp1(PII a,PII b){
    return a.second<b.second;
}
int main(){
    scanf("%d%d%d",&n,&m,&k);
    int a[m];//表示对应下标学校的招生人数
    for(int i=0;i<m;i++)    scanf("%d",&a[i]);
    v.resize(n);
    q.resize(m);
    for(int i=0;i<n;i++){
        int t=0;
        v[i].id=i;
        scanf("%d %d",&v[i].ge,&v[i].gi);
        for(int j=0;j<k;j++)    scanf("%d",&v[i].s[j]);//s数组存储该学生选择的学校
    }
    sort(v.begin(),v.end(),cmp);
    
    //将每个人赋予排名
    v[0].rank=1;
    for(int i=1;i<n;i++){
        v[i].rank=i+1;
        if(v[i].ge+v[i].gi==v[i-1].ge+v[i-1].gi && v[i].ge==v[i-1].ge)
            v[i].rank=v[i-1].rank;
    }
    //for(int i=0;i<n;i++)
        //printf("%d %d %d %d %d %d %d\n",v[i].ge,v[i].gi,v[i].rank,v[i].id,v[i].s[0],v[i].s[1],v[i].s[2]);
    //成绩好的同学优先选择学校
    for(int i=0;i<n;i++){
        for(int j=0;j<k;j++){
            int t=v[i].s[j];//该学生的志愿学校
            int u=q[t].size();//表示该校已经招生的人数
            if(u<a[t]){//已招生的人数小于总的招生人数,则将此学生招进
                q[t].push_back({v[i].rank,v[i].id});
                break;//因为学生符合该学校的招生条件后会将学生招进学校,就不需要考虑后面的志愿了,所以直接break跳出志愿循环(下面同理)
            }
            else if(q[t][u-1].first==v[i].rank){//或者该学生和最后一名的排名一样,那么也要将他招进学校
                q[t].push_back({v[i].rank,v[i].id});
                break;
            }
        }
    }
    
    //打印最后的结果(因为学校村的是排名,所以用pair或者再用一个数组表示对应排名人的编号)
    for(int i=0;i<m;i++){
        sort(q[i].begin(),q[i].end(),cmp1);
        for(int j=0;j<q[i].size();j++){
            if(j!=0)    printf(" ");
            printf("%d",q[i][j].second);
        }
        cout << endl;
    }

    return 0;
}

好好学习,天天向上!

我要考研!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
基于Kubernetes的k3d集群可以使用admission webhook来验证和修改资源对象。下面是一个简单的k3d admission webhook的演示: 1. 创建一个名为`validating-webhook.yaml`的文件,内容如下: ```yaml apiVersion: admissionregistration.k8s.io/v1 kind: ValidatingWebhookConfiguration metadata: name: example.k3d.local webhooks: - name: example.k3d.local clientConfig: service: name: example.k3d.local namespace: default path: "/validate" caBundle: "" rules: - apiGroups: - "" - "extensions" - "apps" apiVersions: - "v1" - "v1beta1" - "v1beta2" operations: - CREATE - UPDATE resources: - "pods" - "deployments" - "replicasets" failurePolicy: Fail sideEffects: None admissionReviewVersions: - v1 - v1beta1 ``` 这个文件定义了一个名为`example.k3d.local`的验证webhook,它将验证和修改`pods`、`deployments`和`replicasets`资源对象。 2. 创建一个名为`deployment.yaml`的文件,内容如下: ```yaml apiVersion: apps/v1 kind: Deployment metadata: name: nginx-deployment spec: replicas: 3 selector: matchLabels: app: nginx template: metadata: labels: app: nginx spec: containers: - name: nginx image: nginx:1.14.2 ports: - containerPort: 80 ``` 这个文件定义了一个名为`nginx-deployment`的Deployment对象,它将创建3个Nginx容器。 3. 创建一个名为`Dockerfile`的文件,内容如下: ```dockerfile FROM python:3.7-alpine RUN pip install flask COPY app.py /app.py CMD ["python", "/app.py"] ``` 这个文件定义了一个基于Python 3.7的Docker镜像,它将安装Flask并运行一个名为`app.py`的应用程序。 4. 创建一个名为`app.py`的文件,内容如下: ```python from flask import Flask, request, jsonify import json app = Flask(__name__) @app.route('/validate', methods=['POST']) def validate(): admission_review = request.get_json() resource = admission_review['request']['object'] if resource['kind'] == 'Deployment': if resource['metadata']['name'] != 'nginx-deployment': return jsonify({'response': {'allowed': False, 'status': {'reason': 'Name is not nginx-deployment'}}}) return jsonify({'response': {'allowed': True}}) if __name__ == '__main__': app.run(debug=True, host='0.0.0.0', port=8080) ``` 这个文件定义了一个Flask应用程序,它将验证`Deployment`对象的名称是否为`nginx-deployment`。 5. 构建Docker镜像: ```shell docker build -t k3d-admission . ``` 6. 创建一个名为`k3d-cluster.yaml`的文件,内容如下: ```yaml apiVersion: k3d.io/v1alpha2 kind: Cluster nodes: 1 name: k3d-admission ports: - port: 8080:8080 protocol: TCP image: rancher/k3s:v1.20.4-k3s1 wait: true ``` 这个文件定义了一个名为`k3d-admission`的k3d集群,它将暴露端口8080以便验证webhook服务可以访问。 7. 创建k3d集群: ```shell k3d cluster create -f k3d-cluster.yaml ``` 8. 部署验证webhook服务: ```shell kubectl apply -f validating-webhook.yaml kubectl apply -f deployment.yaml ``` 9. 验证验证webhook服务是否工作: ```shell kubectl create deployment nginx --image=nginx:1.14.2 ``` 这个命令将创建一个名为`nginx`的Deployment对象,但是由于它的名称不是`nginx-deployment`,验证webhook服务将拒绝它的创建。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值