PAT 1083 List Grades

1083 List Grades

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name[N] ID[N] grade[N]
grade1 grade2

where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade's interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1grade2] and are in non-increasing order. Each student record occupies a line with the student's name and ID, separated by one space. If there is no student's grade in that interval, output NONE instead.

Sample Input 1:

4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100

Sample Output 1:

Mike CS991301
Mary EE990830
Joe Math990112

Sample Input 2:

2
Jean AA980920 60
Ann CS01 80
90 95

Sample Output 2:

NONE

总结:这道题目也不难,先输入数据,然后循环筛选出符合条件的数据,最后将符合条件的数据进行排序在打印即可得到最后的正确结果

代码:

 

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;

struct node{
    string name,id;
    int grade;
};
bool cmp(node a,node b){
    return a.grade>b.grade;
}
int main(){
    int n,g1,g2;
    scanf("%d",&n);
    vector<node> w(n),s;
    
    string a,b;
    int t;
    for(int i=0;i<n;i++){
        cin >> a >> b >> t;
        w[i].name=a;
        w[i].id=b;
        w[i].grade=t;
    }
    scanf("%d %d",&g1,&g2);
    if(g1>g2)   swap(g1,g2);
    int index=0;
    for(int i=0;i<n;i++)
        if(w[i].grade<=g2 && w[i].grade>=g1)    s.push_back(w[i]);
    
    if(s.size()==0)    puts("NONE");
    else{
        sort(s.begin(),s.end(),cmp);
        for(int i=0;i<s.size();i++)    
            cout << s[i].name << ' ' << s[i].id << endl;
    }
    return 0;
}

柳神的代码:

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
struct stu {
    char name[12];
    char id[12];
    int grade;
};
int cmp1(stu a, stu b) {
    return a.grade > b.grade;
}
int main() {
    int n, low, high, cnt = 0;
    scanf("%d", &n);
    vector<stu> v(n);
    for(int i = 0; i < n; i++) {
        scanf("%s %s %d", v[i].name, v[i].id, &v[i].grade);
    }
    scanf("%d %d", &low, &high);
    for(int i = 0; i < n; i++) {
        if(v[i].grade < low || v[i].grade > high) {
            v[i].grade = -1;
        } else {
            cnt++;
        }
    }
    sort(v.begin(), v.end(), cmp1);
    for(int i = 0; i < cnt; i++) {
        printf("%s %s\n", v[i].name, v[i].id);
    }
    if(cnt == 0)
        printf("NONE");
    return 0;
}

好好学习,天天向上!

我要考研!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值