输入一个四位数,将其加密后输出。方法是将该数每一位上的数字加 9,然后除以 10 取余,做为该位上的新数字,最后将千位和十位上的数字互换,百位和个位上的数字互换,组成加密后的新四位数。例如输入 1257,经过加 9 取余后得到新数字 0146,再经过两次换位后得到 4601。
输入格式:
输入在一行中给出一个四位的整数 x,即要求被加密的数。
输出格式:
在一行中按照格式 “The encrypted number is V” 输出加密后得到的新数 V。
输入样例:
1257
输出样例:
The encrypted number is 4601
来源:
来源:PTA | 程序设计类实验辅助教学平台
链接:https://pintia.cn/problem-sets/13/exam/problems/506
提交:
题解:
#include<stdio.h>
int main(void) {
int X;
scanf("%d", &X);
// 按顺序获得四位数的个位、十位、百位、千位上的数字 a、b、c、d
int a = X % 10;
X /= 10;
int b = X % 10;
X /= 10;
int c = X % 10;
X /= 10;
int d = X % 10;
// 对数字进行处理,加 9 模 10
a = (a + 9) % 10;
b = (b + 9) % 10;
c = (c + 9) % 10;
d = (d + 9) % 10;
// 千位与十位交换,即 d 与 b 交换
int temp = b;
b = d;
d = temp;
// 百位与十位交换,即 a 与 c 交换
temp = a;
a = c;
c = temp;
printf("The encrypted number is %04d", d * 1000 + c * 100 + b * 10 + a);
return 0;
}